[xubuntu-users] Can't print any more on 14.04

MR ZenWiz mrzenwiz at gmail.com
Sat Sep 6 23:46:06 UTC 2014

On Sat, Sep 6, 2014 at 4:15 PM, Ince, Wilbur <wilbur at wilbur.us> wrote:
> More importantly, fix your attitude about working with Xubuntu and
> Linux in general.  Nobody asked you to use Xubuntu, you came to this
> decision yourself.  Take responsibility and understand that you will
> have some issues.  If you want to work together with us, welcome
> aboard.  We'll try to help you.
My attitude, as you call it, is from running smoothly with Xubuntu
12.04 for 2 1/2 years, choosing to update to 14.04 and finding so many
things broken.  I have this crazy idea that when new versions come
out, they are improvements.  That has not been the case here, it's
been one problem after another.

I used to work with this stuff all the time and I've forgotten a lot
of the "fixes."  The HPLIP driver sounds good, but I don't see how to
use it on either of the pages you referred me to.  The first one is
old and applies to the 2140 (a model I used to have that also worked
well until the printer itself died).

I don't see any comparable support for the 2240.

I may go get an HP printer since they seem to be more compatible (and
more expensive) with better support (from HP for Linux in general).

Another part of my frustration is that many things have become more
complicated, unnecessarily so IMNSHO, like grub.  It finds my 12.04
installation on my second drive, where I left it, but it can't boot
it.  Apparently the disk UUIDs changed and the prompt I get I don't
recognize and it doesn't tell me how to do anything.

My frustration comes from not being a complete Linux/Ubuntu/Xubuntu or
grub expert, but it seems that I must be in order to get past these
issues.  That's not what you could call effective mass market appeal.

The Ubuntu community, of which I consider myself a part, is pushing to
replace Windows.  With these kinds of issues constantly arising, I
don't see that happening.

I do appreciate all the help I get.  I can't help feeling that I
shouldn't need so much of it.

So, if I want to use that driver (hplip-pcl5e), how do I set the
system up to use it?  I think I may have been doing that before, but
frankly it's been too long and I don't remember the details.

I tried going through the CUPS portal and it still doesn't work.  That
shows that all the print jobs were completed, but nothing came out on
the printer.

One of the few things I absolutely can't do without on this machine is
a working printer.

All help appreciated.

More information about the xubuntu-users mailing list