[xubuntu-users] Xubuntu 14.10 not showing nm-applet - icons missing?

Steve Litt slitt at troubleshooters.com
Fri May 9 02:43:24 UTC 2014

On Thu, 8 May 2014 12:34:40 +0100
Chris Green <cl at isbd.net> wrote:

> I have still not got my nm-applet icon back in the panel on one of my
> xubuntu 14.04 systems.  The network works OK but there's no applet
> icon which can be a bit annoying when connecting to WiFi etc.

Me too. Same, newly installed 14.04 on a laptop.
> The nm-applet can be made to appear by running it as root, it gives a
> warning though:-
>     root at acer-aspire:~# nm-applet &
>     root at acer-aspire:~# nm-applet-Message: using fallback from
> indicator to GtkStatusIcon

I "solved" the problem by putting myself in sudoers as nopasswd for
nm-applet, then I made an Xfce launcher that launched nm-applet in a
terminal using sudo. Works perfectly. Good enough for me, because I
assume sooner or later either it will be fixed, or others will do
writeups on the clean solution.


Steve Litt                *  http://www.troubleshooters.com/
Troubleshooting Training  *  Human Performance

More information about the xubuntu-users mailing list