14.04 seems subject to bug 1046563 with update-manager/notifier

bapoumba bapoumba at ubuntu.com
Sat May 17 20:34:08 UTC 2014

Hello :)

I've been keeping an eye on this.

For 2 days, update-notifier has not reported anything. just checked today
with apt-get and got this from a simulation on upgrade :

The following packages will be upgraded:
  apport apport-gtk python3-apport python3-problem-report
  python3-software-properties software-properties-common

Looking here :
http://people.canonical.com/~ubuntu-archive/phased-updates.html, I see
software-propoerties has currently been offered to 90% of users and is on
day 2, I'll wait for a day or two.
The other one that I have installed and could be upgraded is apport, but it
is being blocked due to
The apport bug seems fixed, but the package offered by apt-get is still
2.14.1 :

Inst apport [2.14.1-0ubuntu3] (2.14.1-0ubuntu3.1
Ubuntu:14.04/trusty-updates [all])

when the fix is in package apport - 2.14.2-0ubuntu1, only available in
utopic for now (I'm on trusty).

So we'll see.

On Sat, May 17, 2014 at 9:36 PM, John Hupp <lubuntu at prpcompany.com> wrote:

> On 5/17/2014 2:57 PM, brendanperrine wrote:
>> On Sat, 17 May 2014 14:37:38 -0400
>> John Hupp <lubuntu at prpcompany.com> wrote:
>>  Some fresh experiences today:
>>> I booted the laptop, manually ran just "update-notifier" from the
>>> terminal (and yes, I did forget to add " &"), and Software Updater
>>> appeared almost immediately to offer a big batch of updates.
>>> Rather inexplicable, but running with it just to see what would happen,
>>> I rebooted without installing anything, added update-notifier to Default
>>> applications for LXSession: Autostart tab, and rebooted again.  The
>>> update-notifier changelog indicates that it is supposed to poll every
>>> 180 seconds.  For good measure I gave it 10 minutes, but Software
>>> Updater did not appear.  I rebooted 10 times and waited 10 minutes each
>>> time, all with the same no-show results.
>>> I also booted the desktop on which I installed 14.04 a couple days ago.
>>> I did not manually run update-notifier but instead set up the
>>> update-notifier workaround in Default applications for LXSession.  I
>>> rebooted and *Software Updater almost immediately offered 140+ MB of
>>> updates*, which I installed.
>>> Back on the laptop, I gave it an Ethernet connection and rebooted 5 more
>>> times, waiting 10 minutes each time.  Still no updates offered.
>>> I removed the update-notifier entry from Default applications for
>>> LXSession: Autostart, pulled the Ethernet plug, switched the WiFi back
>>> on, and rebooted.  I ran "update-notifier &" from a terminal and waited
>>> 10 minutes.  No results.  I did this 5 times.
>>> Then I did the same as above but ran "dbus-launch update-notifier &"
>>> instead.  I did this 3 times with no results.
>>> ------------------------------------------------------------------------
>>> The only hypothesis I can see from the above is that
>>> update-notifier/manager will offer the updates once (per day?), and if
>>> you don't install them it will not offer them again.
>>> Could this be?
>>>  I think in software and updates from the menu is set to check daily by
>> default.
> I see that now, and that may be the simple and good explanation for what
> appeared to be bad behavior.  Though update-notifier runs as a daemon and
> polls every 180s, it is update-manager that actually offers the updates, so
> clearly there is some mechanism between them (which I have asked about here
> before).
> Software-properties-gtk (aka Preferences: Software & Updates) is supposed
> to "manage the repositories that you install software from," and its
> manpage describes it simply as a software sources list editor, but via its
> Updates tab it also seems to govern update-notifier/manager.
> Since it cannot be set to check more often than daily, it looks like I'll
> have to wait until tomorrow to confirm whether it works, but I'll manually
> add update-notifier back to the Autostart list.
> If that succeeds, then there really is no deep problem, only the problem
> with /etc/xdg/autostart that also affects nm-applet, etc., for which we
> have the workaround (and for which a true fix is in the works).
> Thanks, Brendan!
> --
> Lubuntu-users mailing list
> Lubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/
> mailman/listinfo/lubuntu-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20140517/2ff38993/attachment.html>

More information about the Lubuntu-users mailing list