Strange issue upgrading from Edgy to Feisty -- or is it an issue?

Wafa Hakim Orman wafa at
Thu Apr 26 19:18:06 UTC 2007


I went through the standard network install from Edgy to Feisty on my 
desktop & everything worked perfectly. I am now trying to go from Edgy 
to Feisty on my Toshiba A45 Satellite notebook & things are rather weird.

What happens is, I go to adept-manager, I update the repositories, it 
tells me there is a new version available, I click ok, it downloads the 
first update tool & then vanishes. Poof, out of sight. Adept-manager 
stays open but there is no sign of the distribution upgrade interface. 
(On my desktop there was a separate window showing the progress of the 
distribution upgrade.)

When I look through my repositories, I see that they have all been 
changed to Feisty. When I try to exit Adept-manager, it says there are 
uncommitted updates -- it wants to install 1048 new packages, all of 
which are Feisty packages.

This is a work machine with a lot of important software & data on it (at 
least the data is safe in its own /home partition) but will it be safe 
to just let it install all those Feisty packages? Will that achieve a 
distribution upgrade, as seamless as on the other computer?

I don't know if this is important, but when I went from Dapper to Edgy 
on this notebook that is now acting funny, I had used the network 
upgrade, just changing all instances of dapper to edgy in my 
sources.list & doing apt-get dist-upgrade. On the desktop, that had not 
worked so I had to format the / partition & install Edgy from a cd. Now 
it looks like the roles may have been reversed between my two machines...

Any ideas?

Thanks in advance,

"So it goes."
	--Kurt Vonnegut

More information about the kubuntu-users mailing list