nvidia drivers ....

Luca Mollica mollica.luca at hsr.it
Tue Feb 28 09:24:10 GMT 2006


Dear users,

I am experiencing some troubles with Nvidia video card set up on two
different machine (a laptop and a desktop machine). I perfectly know
that this issue has been already covered in this mailing list and
elsewhere as well, but the strange fact is that after installing kernel
source and headers, compilers etc.  (I am referring to kernel
2.6.12-9-386 compiled with gcc 3.4) I am able to restart KDE , see the
NVIDIA logo on my screen and to see 3D acceleration enabled (glxinfo)
and glxgears.
So far so good .... but after rebooting the system kubuntu is not able
to recognize the monitor and only text mode is available, the tty on
which I should have the screen is hanged on something like 'battery
check' before reaching the correct display features and other tty are
accessible for user/root login. This is the first time I am facinfg with
a problem like that, and after many trials (and internet searches of
course !) the issue is not solved: does anyone have advices about it ?

Attached to this mail you can find both xorg.config file.
Moreover, please note that I have also followed the detailed
instructions found in this page:
http://www.zwhlug.nl/content/nvidia_nvidia_driver_1_0_8178_installation_on_ubuntu_breezy_5_10

Thanx to you all in advance for the answer ...

LM


-------------- next part --------------
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister at builder3)  Wed Dec 14 16:39:22 PST 2005


Section "ServerLayout"
    Identifier     "Layout0"
    Screen        "Screen0" 0 
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection



More information about the kubuntu-users mailing list