USB mount problem since SATA hdd install.

Mark Kelly kubuntu at
Fri Feb 10 21:31:37 UTC 2006


I'm running Kububtu 5.04 x86, and I have a problem with the usb hotplug 
system. It all worked perfectly (user could insert and use their own usb 
sticks, icons popped up on the desktop, very nice) until I added a SATA hdd 
to the system. 

Now, only the main user (me, the first user created during install) can use 
usb devices. The icons still appear on the desktop, but clicking on them 
results in an empty Konqueror window (path media:/sdb1) and an error 

    Could not mount device.
    The reported error was:
    mount: could not find /dev/sdb1 in /etc/fstab or /etc/mtab.

If I mount the drive (a compact flash card reader) it's fine only for me - 
flipping to my wife's login in another session still doesn't get her access 
- this time the message is

    Could not enter folder /media/sdb1

The SATA drive I added is not mounted or used at all from Kububtu, in case 
that is relevant. I have tried several usb devices (I have an external hdd 
for backups and a thumb drive) with the same results.

Has anyone any idea how I can fix this? It would be nice if my wife could 
get her pictures off the card - I feel terribly guilty as it was my idea to 
add the new drive :)



More information about the kubuntu-users mailing list