on error KsCD becomes unkillable and causes umount to fail on shutdown...

Art Alexion art.alexion at verizon.net
Thu Feb 2 19:05:45 UTC 2006

Joe(theWordy)Philbrook wrote:

> It would appear that on Wed Feb 1, art.alexion did say:
> >No suggestions for preventing it from happening, but to avoid restarting
> >sudo killall kscd
> >Joe(theWordy)Philbrook wrote:
> >>When this happens I can't kill the kscd process even when
> >>I run ksysguard with root privileges.
> Actually I did try killall as a normal user. (the same user who ran
> startx and who started kscd and who ksysguard listed for the kscd
> process) I still think it should have worked just as looking up the pid
> with ps -A and doing a kill -15, and then in frustration a kill -9
> should have...

> I don't know of any reason why a root permission killall would work
> better than a root permission ksysguard, But if it happens again I will
> certainly try your suggestion.

Because some root process has grabbed the CD-ROM drive.

> Speak of the devil... I just tried to stop kscd from playing my Phil
> Collins cd only to avoid the issue I tried the eject button instead of
> stop... So here goes:
> Well anyway, thanks for the suggestion, it was worth a try!

What version of Kubuntu/KDE/kernel are you using?  I have
breezy/3.4.3/2.6.12-10-686 and am having a ton of problems with the CD
drive.  Often I can't eject without being root (hardware button does
nothing; eject control on kscd yields an error; command line eject just
hangs; but sudo eject works fine).  The disk drawer opens randomly, even
in the middle of ripping a CD (so far, not when burning one -- fingers
crossed).  No desktop icon for disks, and the kde 3.5 solution isn't
available in 3.4.3.

Some nice things about breezy, but many things are broken that worked
well in hoary.  I can't believe the brave souls who are working with
dapper.  Right now the most surprisingly functional software I'm running
is Firefox 1.5, direct from Mozilla.com.  I think the 6 month Ubuntu
upgrade policy is too ambitious -- developers working on dapper before
fixing breezy.

Art Alexion
Arthur S. Alexion LLC

PGP fingerprint: 52A4 B10C AA73 096F A661  92D2 3B65 8EAC ACC5 BA7A
The attachment -- signature.asc -- is my electronic signature; no need
for alarm.
Info @

Key for signed PDFs available at
The validation string is TTJY-ZILJ-BJJG.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 374 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20060202/78c90b37/attachment.sig>

More information about the kubuntu-users mailing list