Big Problem with Apt-Get

Abdullah Ramazanoglu ar018 at yahoo.com
Thu Apr 28 11:28:08 CDT 2005


Dave - dedi ki:
  --8<--

> apt-get update - works fine
> 
> apt-get upgrade - downloads the files but then I get this no matter what
> I do. Can't even install a new app without the same error.
> 
> "E: /var/cache/apt/archives/kdelibs4-dev_4-
> 0x1.6378200000045p-1363.4.0-0ubuntu3.1_i386.deb: files list file for
> package `klettres-data' is missing final newline"

Did you mix external repositories such as marillat or Breezy? If no, then
there should really nothing much to upgrade as Kubuntu 5.04 archives are
in stable condition. If yes, then sorry, but you're getting what you ask
for. As a general rule of thumb I wouldn't "upgrade" after mixing in
external repositories. I would have done whatever I'd like to do with
official repositories first, and after getting the system to its peak
state within official repos, only after then, I would add external repos
and then do no more global operations like "upgrade", unless doing some
fine pinning first.

BTW I'd very much like if someone got a pointer to optimum pinning
practices with certain popular unofficial repos.

Best regards
-- 
Abdullah Ramazanoglu
aramazan ÄT myrealbox D0T cöm




More information about the kubuntu-users mailing list