[xubuntu-users] hibernation in Xubuntu 17.04

Istimsak Abdulbasir saqman2060 at gmail.com
Fri Jun 30 21:59:26 UTC 2017

This was a painful research.

To use hibernate (or suspend2) requires your system to have a *"tuxonice"*
enabled kernel. If you are using such a kernel, then you should see the
*suspend2* component in either* "/proc/suspend2"* or "*/sys/power/suspend2".
*The kernel patch will allow you to resume your system from your disk if
you decide to use suspend2.

Unfortunately, the* "tuxonice"* patch for the kernel is not available on
its website. This is what its website looks like(not very technical).
http://www.tuxonice.net/. I doubt running *"hibernate"* from the console
will work.

However, there is a github project that offers the patch.
https://github.com/pierre/tuxonice-fastboot. I will be checking this out


On Fri, Jun 30, 2017 at 1:59 PM, Mike Miller <mbmiller+l at gmail.com> wrote:

> I think my first attempt to post got stuck in moderation (recapped
> below).  I am new to the list and I wasn't properly subscribed when I
> sent it.
> I've been working on this for many hours with only some progress.
> Suspend always worked.  Hibernate (to disk) has not worked, yet.
> Using "Hibernate" from the system's "Log Out" menu, the screen blanks,
> it shuts down, but when I power back up it seems to go through a
> normal boot process and I don't recover my previous state.
> Using sudo "pm-hibernate", I can see it saving the page files, and
> when I try to recover I see it loading the page files up to 99% and
> the screen blanks.  After that I get only a black screen.  It responds
> to nothing, so I have to power off.
> Any ideas?
> Best,
> Mike
> ---------- Forwarded message ----------
> From: Mike Miller <mbmiller+l at gmail.com>
> Date: Wed, Jun 28, 2017 at 6:45 PM
> Subject: hibernation in Xubuntu 17.04
> To: xubuntu-users at lists.ubuntu.com
> Installation of 17.04 on my laptop was a breeze.  Truly a joy and it's
> working great, except for this one bothersome thing.  Maybe there is a
> FAQ, but I didn't find it and things might be a little different with
> 17.04 because of the use of swapfiles instead of swap partitions.
> I discovered that pm-hibernate wasn't installed by default, so I
> installed the pm-utils.  However, when I try to use it (as in sudo
> pm-hibernate), I got an error.  Logs show it goes through all of the
> steps perfectly right up until it is supposed to hibernate, then it
> fails and goes back through a series of "wake" steps.  So the screen
> blacks for a sec and I'm back to the bash prompt.
> The error I see in /var/log/pm-suspend.log is
> sh: echo: I/O error
> That follows immediately after "performing hibernate" and before
> "Awake."  There are only three seconds between those lines.
> My guess, based on some searches, was that my problem was that I
> didn't have a proper swapfile.  Now we use swapfile instead of swap
> partition, right?  So I looked for info on how to create that
> swapfile, and it seemed to work.  I think I have a proper swapfile but
> I'm not sure how to test that.  sudo swapon --show seems to give
> appropriate output but I'm not sure what PRIO of -1 is telling me.
> Any ideas?
> Best,
> Mike
> --
> xubuntu-users mailing list
> xubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/
> mailman/listinfo/xubuntu-users

"Collaboration is the new innovation" (Istimsak Abdulbasir, 2016)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20170630/6523f9f8/attachment.html>

More information about the xubuntu-users mailing list