[xubuntu-users] A3 printer is printing page cropped to A4

Peter Flynn peter at silmaril.ie
Thu Oct 9 22:06:15 UTC 2014

This error sprang on me (and apparently others) some  months ago.

I have two HP A3 printers (K7100 at home, K8600 in office) both on
Ubuntu systems. Both have been working fine for several years printing
both A4 and A3.

I have two print queues defined in CUPS, one with a default A4 page size
and one with a default A3 page size, because if you only define one, it
will print the default image area only, no matter what paper size you
specify in the print dialog.

[Aside: this seems to be a major bug in CUPS which has always been
there: you have to establish a separate print queue for each paper size
you want to print on the same printer: you cannot use the print dialog
to change paper size UP, only DOWN. Strangely, no-one seems to be aware
of this except users migrating from Windows and Macs, who think it very
odd that you have to have a separate queue for each paper size.]

I went several months earlier this year without any A3 jobs, but when I
tried to print one in August, it printed the page image clipped to A4,
exactly as if I had tried to print an A3 PDF on the A4 printer. This
happens regardless of the driver (hpcups vs hpijs), and regardless of
whether you have hplip installed or not.

I have checked and re-checked, and nothing has changed in my own
settings, and I *was* using the A3 print queue. The K7100 is shared on
my home network, and exhibits the error from systems running Precise,
Saucy, and Trusty, and from an iMac (which of course also runs CUPS).
The K8600 in the office is not shared, and is cabled to a machine
running Saucy.

Many of the pages on the web reporting this have said that they
discovered that their PPD file didn't define A3, or similar omissions,
so today I got around to examining both the hpcups and hpijs PPDs, and
they appear to be correct: all the dimensions for A3 are right,
including the image area. This is true both for the PPDs in /etc/cups
and those (gzipped) ones in the HP software install directories.

Given the fact that both setups were demonstrably working perfectly at
the start of this year, I am beginning to think that it might not be
CUPS (the obvious suspect, given its unreliability) or HP (the second
suspect, given their weird Linux support).

CUPS relies on a set of filters, which used to be part of CUPS but which
I believe were spun off as a separate (several separate?) packages when
Apple relinquished maintenance of them, and are now in cups-filters. I
suspect that this package contains the bug, and was perhaps updated
during this year. As I trustingly run updates weekly, with only a brief
eyeball down the list, I wouldn't have thought to reject something so

How do I find out when updates for cups-filters (if any) were pushed out
during 2014? Is it possible some fix for something unrelated has
resulted in a line being dropped from the filters, which is resulting in
the ImageableArea value from the PPD files being ignored?

I do have one final test: uncable the home printer and carry it into the
room where the iMac is, and plug it in direct (thus bypassing the server
in the study, which is running Precise). I should probably also compare
the PPD files on the iMac with those on the Linux systems.

Has anyone else had this, or seen it resolved?


More information about the xubuntu-users mailing list