[xubuntu-users] mousepad wiped out file content when font change tried

Chris Spackman chris at osugisakae.com
Tue Jul 15 13:33:14 UTC 2014

On 2014/07/15 at 01:32am, Juan R. de Silva wrote:

> Editing a file in Mousepad I wanted to change to Italic font. I opened 
> View->Select Font, selected Italic and clicked OK. And...
> Suddenly all text disappeared. I tried to close the file and, quite 
> logically in this situation, selected DO NOT SAVE when I was prompted.

I have seen similar, on occasion, when changing the font while working
on Japanese text. If the font doesn't include the characters, it
cannot show them.

My guess is that something like this may have happened in your
case. The font could not show the characters (perhaps it didn't have
them in italics), so it showed nothing. That doesn't mean the text has
been deleted, just that the software cannot *show* the text with that
font. Whenever something like this happens, try a different font
before assuming that the text has been deleted.

Sorry, I wish I could help with recovering your data, but that is
beyond my ken. Hopefully this can help next time, though.

Chris and Yoshiko Spackman

Respect is earned. Trust is gained. Loyalty is returned.

More information about the xubuntu-users mailing list