[xubuntu-users] Grub breaks after kernel 3.5.0-23

mikeossur at altoonawa.org mikeossur at altoonawa.org
Sat Feb 23 19:58:06 UTC 2013

Hi Everyone,
    I am running on a raid box. I am using a arc-1110 raid card.  I 
installed Xubuntu with little trouble.
I have done kernel updates with no issues until I reached kernel 
3.5.0-23 when I was presented with the Grub> prompt.

No issues, I found how to fix it on the net with the commands below.

Grub> set prefix=(hdx,y)/boot/grub

Grub> insmod (hdx,y)/boot/grub/linux.mod

Grub> insmod part_msdos

Grub> insmod ext2

Grub> insmod gzio

Grub> set root=(hd0,1)

Grub> linux /boot/vmlinuz-xx...xx-image root=/dev/sda1 ro

Grub> initrd /boot/initrd.img-xx...xx-image

Grub> boot

Then I upgraded to 3.5.0-25 and I had a kernel panic.  I am back to 
3.5.0-23 after passing the above parameters. I am afraid to
reboot my machine right now because I am not sure if I am not going to 
have to do this everytime.

I tried update-grub and removing 3.5.0-25 .  It worked once but not the 
second time when reverting back to 3.5.0-23

What is wrong with the Grub script to cause all this hell?


More information about the xubuntu-users mailing list