[xubuntu-users] New Karmic install: problem with postfix "local loopback still a problem"

Joe(theWordy)Philbrook jtwdyp at ttlc.net
Sun Jul 11 13:38:06 UTC 2010

It would appear that on Jul 10, Joe(theWordy)Philbrook did say:

> Anyway I got this brilliant idea to try to copy the postfix config from
> my laptops Arch where local loopback is working...
> I even managed to get newaliases to create a new db...
> Trouble is every time I try to send a user a mailx from root I get this:
> postdrop: warning: unable to look up public/pickup: no such file or directory
> What is that talking about?
> Still confused:

Now I'm even MORE confused. I've rebooted several times since then. Without
the local mail issue resolving itself. I basically filed the issue under pipe
dreams and decided I'd have to live without it... But since the only other
configuration issue that I haven't solved is that the HDA NVidia (Alsa mixer)
that's being used by both the other installed linux isn't being found in
Xubuntu, I decided that it was time to see if I could set up a direct boot
entry in my grub classic boot partition for Xubuntu that doesn't depend on
chainloading the grub2 that's installed to Xubuntu's root partition...

And as soon as I booted using the copies of the vmlinus and initrd files I
placed on my boot partition, I got a "no mail" notice upon console login.
(I uninstalled gdm to get classic text mode login and use startx when/if I'm
ready to put up with X)

I don't understand. But I booted this morning, poked around and tried the
mailx thing without success. But the only system change I made was to copy
the vmlinuz and initrd files, and set up the below grub entry, and suddenly
root can type:
mailx jtwdyp

And instead of getting that error about "public/pickup" a mail with a
 Subject: of "tst" and a body consisting of "tst" shows up in jtwdyp's
inbox... Go figure!

the classic grub boot entry is as follows:

title           Xubuntu kernel 2.6.31-22-genericXubuntu9.10karmic Xubuntu_desk-8
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.31-22-genericKarmic root=LABEL=Xubuntu_desk-8 ro vga=normal
initrd          /boot/initrd.img-2.6.31-22-genericKarmic

But I can't see why that would matter... Unless maybe that
annoying splash screen I avoided is somehow responsible???

For comparison, heres the grub2 entry with which mailx wasn't working

menuentry "Ubuntu, Linux 2.6.31-22-generic" {
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        set quiet=1
        insmod ext2
        set root=(hd1,8)
        search --no-floppy --fs-uuid --set 5de83da5-a135-4f3d-8655-40ba9e533c99
        linux   /boot/vmlinuz-2.6.31-22-generic root=UUID=5de83da5-a135-4f3d-8655-40ba9e533c99 ro   quiet splash
        initrd  /boot/initrd.img-2.6.31-22-generic

Hmmmnnnn Now that's odd. if my boot part LABEL=myBoot_desk-2 is on what
grub classic calls (hd0) {and it's certainly on the same drive as my 
LABEL=Xubuntu_desk-8 partition, Why does grub2 set root to a (hd1)

The drive in question is an IDE drive (if it matters) and the only other
hard drive is a direct connect sata drive... ( my bios finds the ide drive's
MBR before it finds the sata drive's MBR BTW...

|  ~^~   ~^~
|  <?>   <?>       Joe (theWordy) Philbrook
|      ^                J(tWdy)P
|    \___/         <<jtwdyp at ttlc.net>>

More information about the xubuntu-users mailing list