[xubuntu-users] speeding up 7.10 by upgrading to 686 kernel

Franji Mayes jfmayes at gmail.com
Wed Nov 28 02:07:57 UTC 2007

Radomir, thank you so much for your patience and help!

I ran "fsck" while logged in as root. It said:

fsck 1.40.2...
e2fsck 1.40.2...
/dev/sda1: clean, 102623/694880 files, 494744/1389614 blocks"

Then I ran "fsck -c" and it said

"Checking for bad blocks (read-only test)" and had numbers counting. Then it
started displaying a lot of cryptic information, the only lines of which I
recognized were several "...Buffer I/O error on device sda1, logical

Then it said "done". Then

"Pass 1: Checking inodes, blocks and sizes
Pass 2: chekcing directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #23 (25450, counted=25448). Fix?"

I answered "yes" to that question, and 3 more of similar nature. Then it

"/dev/sda1: *******FILE SYSTEM WAS MODIFIED******
/dev/sda1: ******* REBOOT LINUX ************
/dev/sda1: 102625/694880 files (0.6% non-contiguous), 494771/1389614 blocks"

I wasn't sure if that meant it's repaired or not, so I again tried "apt-get
install linux-686" and received messages about it not being able to write to
files. So I ran "mount / -o rw, remount" and the apt-get again, and it
displayed a few lines, at the end of which it said "E: Couldn't find package
linux-686" I Googled and found "aptitude install linux-686" and ran that; it
seemed to do more stuff, but still couldn't find the package.

So I guess the good news is that my system seems to be repaired/working and
now I just have to figure out how to get the 686 kernel (assuming that will
help my slow performance).

> Tue, Nov 27, 2007 at 10:45:36AM -0800:
> > > Mon, Nov 26, 2007 at 09:12:40PM -0800:
> > > > install a kernel for a 686. The documentation said to type "sudo
> > > > apt-get install linux-686" from the command line. I was logged in as
> > > > root, so I typed the above w/out "sudo". I got a bunch of errors,
> all
> > > > of which contained the text "Buffer I/O error on device sda1,
> logical
> > > > block".
> > >
> > > I don't want to worry you, but these kinds of errors usually mean
> > > a hardware failure of the sda1 disk (probably a hard disk in this
> case).
> > >
> > > Try booting in the recovery mode and running fsck on that disk,
> possibly
> > > with -c option to check for bad blocks.
> > I typed "fsck"  into the command line and hit return, and got the
> following:
> >
> > "fsck 1.40.2 (12-Jul-2007)
> > e2fsck 1.40.2 (12-Jul-2007)
> > /dev/sda1 is mounted.
> > WARNING! Running e2fsck on a mounted filesystem may cause SEVER
> filesystem
> > damage. Do you want to continue?"
> > That sounded scary so I said "no". Should I say "yes" to that question?
> Yes, it's normal, forgot to tell you about it. Type 'mount' to make sure
> the partition is mounted read-only (it should be in the recovery mode, but
> better safe than sorry). If it is not, type:
>  mount / -o ro,remount
> this should remount it in read-only mode, making sure that the filesystem
> is not corrupted during checking. An alternative would be booting from
> a livecd, then the system is not mounted, but with your specs this might
> be slow. So, make sure it's read only and answer 'yes' to that question.
> > If my disk is bad, did I ruin it by changing from Windows to Linux?
> That's not possible, it's a physical fault.
> > Can
> > damage like that be caused by the disk running for too long? (It was on
> for
> > almost a day while I was trying different install methods.)
> Only if there is something wrong with cooling or you kept it in posistion
> where proper cooling was not possible.
> > I didn't have
> > too many problems w/ XP on it, but maybe they were there and I didn't
> know
> > about it until now. If the disk is bad, how was Linux able to be
> installed
> > at all?
> We are not sure if it's bad. That's the usual reason for these errors, but
> there can be other -- that's why you're running a disk check. Also, if
> only some parts of the disk are bad, fsck can mark them as such and the
> system will just not use them for storing data.
> --
> Radomir `The Sheep' Dopieralski <http://sheep.art.pl>
> ()  ascii ribbon campaign - against html e-mail
> /\  <www.asciiribbon.org> - against proprietary attachments
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20071127/5b1855e8/attachment.html>

More information about the xubuntu-users mailing list