[ubuntu-za] Need urgent help with m5 simulator for ubuntu12.04?

Wayne Abroue plettpc at gmail.com
Fri Sep 27 06:13:33 UTC 2013

To build gem5, you will need the following software:

    21 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l21>
g++ version 4.3 or newer.

    22 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l22>
Python, version 2.4 - 2.7 (we don't support Python 3.X). gem5 links in

    23 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l23>
    Python interpreter, so you need the Python header files and shared

    24 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l24>
    library (e.g., /usr/lib/libpython2.4.so) in addition to the

    25 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l25>
    executable. These may or may not be installed by default. For

    26 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l26>
    on Debian/Ubuntu, you need the "python-dev" package in addition to

    27 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l27>
    "python" package. If you need a newer or different Python

    28 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l28>
     but can't or don't want to upgrade the default Python on your

    29 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l29>
     see http://www.gem5.org/Using_a_non-default_Python_installation

    30 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l30>
SCons, version 0.98.1 or newer. SCons is a powerful replacement for

    31 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l31>
    If you don't have administrator privileges on your machine, you
can use the

    32 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l32>
    "scons-local" package to install scons in your m5 directory, or
install SCons

    33 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l33>
    in your home directory using the '--prefix=' option.

    34 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l34>
SWIG, version 1.3.34 or newer

    35 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l35>
zlib, any recent version. For Debian/Ubuntu, you will need the
"zlib-dev" or

    36 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l36>
    "zlib1g-dev" package to get the zlib.h header file as well as the

    37 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l37>

    38 <http://repo.gem5.org/gem5-stable/file/07352f119e48/README#l38>
m4, the macro processor.

On Fri, Sep 27, 2013 at 5:40 AM, Graeme Donaldson
<graeme at donaldson.za.net>wrote:

> To expand on what Wesley has said, on Ubuntu you need the
> "build-essential" package which includes various tools for building
> software from source code.
> In a terminal:
> sudo apt-get install build-essential
> This may not solve it completely, you may run into more errors if you need
> specific development libraries, but for now install build-essential, try
> again and report back to us .
> Graeme
> Sent from a mobile device, please excuse my brevity.
>  On 26 Sep 2013 9:29 PM, "Wesley Werner" <wesley.werner at gmail.com> wrote:
>> Hello Navdeep. I have not built that app in particular but here are some
>> guides:
>> The distro you use is irrelevant, it seems like you just need the
>> development tools installed to build from source.
>> It reads like you need the gcc compiler installed. But there may be more,
>> depends on what the source is linking to.
>> Usually all sources have README and INSTALL files that give steps for
>> what you need to build. The second place to look is for a manual on the
>> application site, the install & building sections.
>> http://www.m5sim.org/Dependencies
>> --
>> Sent via K-9.
>> Navdeep Singh Sidhu <navdeepsingh.sidhu95 at gmail.com> wrote:
>>>  I was helping my friend installing gem5 simulator on Linux for her
>>> thesis work. i know linux a little bit. Somehow i managed to install that
>>> simulator on my laptop with ubuntu 12.04, but when i tried to install that
>>> simulator on her laptop that didn't went well. i gave the same commands on
>>> her laptop but it gave this error.
>>>         $ scons build/ALPHA/gem5.opt
>>>          scons: Reading SConscript files ...
>>>          Error Don't know what compiler options to use for your compiler.
>>>          compiler: None
>>>          version: COMMAND NOT FOUND!
>>>          If you're trying to use a compiler other than GCC
>>>          or clang, there appears to be something wrong with your
>>>          environment.
>>>          If you are trying to use a compiler other than those listed
>>>          above you will need to ease fix SConstruct and
>>>          src/SConscript to support that compiler.
>>> I tried same commands to install gem5 simulator by re installing ubuntu
>>> on her laptop. But same error. then i tried on Linux mint 15 & fedora. but
>>> i got same error. Plz somebody guide me what is wrong i'm doing. If any
>>> body can provide step by step info to perform installation of gem5
>>> simulator or anybody can provide me a .deb file of sim that will be really
>>> helpful.
>>> If not please at-least guide me how to create deb file of that sim? But
>>> please consider my skills are of beginner's level.
>>> it is very urgent for our thesis work.
>>> It worked on 2 out of 6 machines. Working on my machine & on one another
>>> machine in computer lab of our university.
>>> regards
>>> Navdeep Singh
>>> --
>>> ubuntu-za mailing list
>>> ubuntu-za at lists.ubuntu.com
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
>> --
>> ubuntu-za mailing list
>> ubuntu-za at lists.ubuntu.com
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
> --
> ubuntu-za mailing list
> ubuntu-za at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20130927/3b98a6db/attachment.html>

More information about the ubuntu-za mailing list