[ubuntu-za] Need urgent help with m5 simulator for ubuntu12.04?

Navdeep Singh Sidhu navdeepsingh.sidhu95 at gmail.com
Thu Sep 26 18:59:57 UTC 2013

I was helping my friend installing gem5 simulator on Linux for her thesis
work. i know linux a little bit. Somehow i managed to install that
simulator on my laptop with ubuntu 12.04, but when i tried to install that
simulator on her laptop that didn't went well. i gave the same commands on
her laptop but it gave this error.

        $ scons build/ALPHA/gem5.opt
         scons: Reading SConscript files ...
         Error Don't know what compiler options to use for your compiler.
         compiler: None
         version: COMMAND NOT FOUND!
         If you're trying to use a compiler other than GCC
         or clang, there appears to be something wrong with your

         If you are trying to use a compiler other than those listed
         above you will need to ease fix SConstruct and
         src/SConscript to support that compiler.

I tried same commands to install gem5 simulator by re installing ubuntu on
her laptop. But same error. then i tried on Linux mint 15 & fedora. but i
got same error. Plz somebody guide me what is wrong i'm doing. If any body
can provide step by step info to perform installation of gem5 simulator or
anybody can provide me a .deb file of sim that will be really helpful.

If not please at-least guide me how to create deb file of that sim? But
please consider my skills are of beginner's level.

it is very urgent for our thesis work.

It worked on 2 out of 6 machines. Working on my machine & on one another
machine in computer lab of our university.


Navdeep Singh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20130927/37158a75/attachment.html>

More information about the ubuntu-za mailing list