[ubuntu-za] Update - CellC ZTE MF190 7.2Mb/sec white modem (Paul Young)

Paul Young paulysa at gmail.com
Wed Oct 5 14:02:24 UTC 2011

Hi all. The short version. the xD card and modem work. Modem will connect to
either VodaCom or CellC using HSPA+ and te xD card works at the same time.

>>>Long version>>>
Have done a bit of reading up.


Looks like ZTE MF190 is a virtual CD/(xD card and modem). Ubuntu has of must
have something called  usb_modeswitch *to do the s*witching between virtual
CD (which disappears under Windows XP when drivers are installed) and the
xD/Modem options is the problem. Ubuntu mounts device a virtual CD (dmesg
did show this). Curious as it does not even need this functionality - only
Windows XP uses this - at least my XP VirtualBox installation did. Should
have just unmounted the virtual CD (CellC desktop icon) - which came as an
afterthought. This is strange since when I had the black modem (before it
got stolen :-( ) it worked under Ubuntu 10.10  - nothing needed other than
to plug it in. I think the firmware that manages the multifunctional USB
options in this modem has changed somewhere along the line, so all one must
do is plug the modem in, unmount the CellC icon which appears and the modem
will work - tried it 5 times to verify....

OR here is the fix from the first website I mentioned:

*How to get your Cell-C USB dongle to connect to the internet using Ubuntu

*Step 1:*

Open up a terminal (Applications > Accessories > Terminal) and install

*sudo aptitude install usb_modeswitch*

*Step 2:*

Update your system:

sudo updatedb

Find the newly installed config file: usb_modeswitch.conf

*sudo locate usb_modeswitch.conf and open it to edit with vi / nano / your
own pref. app.

(It will be located in *etc/usb_modeswitch.conf*)

*sudo nano /etc/usb_modeswitch.conf*

*Step 3:*

Add the following text to the bottom of the file and save:

DefaultVendor=  0x12d1
DefaultProduct= 0x1446
TargetVendor=	0x12d1
TargetProduct=	0x1001
MessageEndpoint=	0x01
MessageContent=	"55534243000000000000000000000011060000000000000000000000000000"

*Step 4:*

In your terminal start “sudo usb_modeswitch”

*sudo sudo usb_modeswitch*

*Step 5:*

Right, you’re done with the Terminal. Now for the GUI.

Open up System > Preferences > Network Connections > Mobile Broadband Tab >
You should see something like “Create a connection for this device – HUAWEI
Technology HUAWEI Mobile”
Go through the Wizard, select “South Africa”, “Cell-C”, and the “Default
Plan” – “Apply”.
Click on the new connection you’ve just added and click Edit.

There will be a lot of configuration already done for you. What you need to

   - “Tick” connect automatically.
   - “Tick” available to all.
   - Remove the username where it says cellc and leave it blank.
   - Add the password (this is the PIN that’s set on your SIM Card. 0000
   (zeros) by default.
   - Click Apply. You’re connected! (If you did not select “Connect
   Automatically” you’ll have to select the connection via the Network
   connection manager (top right on the Desktop).

Let me know if you have any issues – but this’ the easiest 5min-work-around
Ubuntu has seen in a long time!

Paul Young
Phone: +27 (0) 31 822 1632 / 566 2608
Mobile: +27 (0) 84 247 1544
Skype: paulysa
Facebook: http://www.facebook.com/paulysa1969
Twitter: http://twitter.com/paulysa1969
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20111005/8967cf87/attachment.html>

More information about the ubuntu-za mailing list