[ubuntu-za] Mousekeys problem on Samsung

David Robert Lewis (ethnopunk) ethnopunk at telkomsa.net
Tue Mar 2 22:37:43 GMT 2010

David Robert Lewis (ethnopunk) wrote:
> Wesley Werner wrote:
>>     In other words I want the default to be a left click and the
>>     simulation
>>     to be a right click. Left clicking is what one does to grab stuff and
>>     select. It's not available which is very annoying. Ubuntu got
>>     things the
>>     wrong way round.
>>     Right click should be ctrl plus click pad!
>>     _DRL
>> Hi David
>> Are you able to select text with the one-click button at least? If so 
>> you can use ctrl+shift+c to copy text, and ctrl+shift+v to paste.
>> There is a utility called mousetweaks 
>> <https://help.ubuntu.com/community/Accessibility#Keyboard%20Modifiers> 
>> that simulates right-clicks, that is one option. The best option is a 
>> usb mouse if you have one ;)
>> System -> Prefs -> Accesibility options, under keyboard section, you 
>> can enable "mouse keys" to contorl the cursor via the keypad, but some 
>> notebooks don't have those either.
>> OT: Glad its a new month, Im online again! :)
> Can't select anything. Need to default to left click so I can select and 
> grab stuff. Right-click should be emulated as in ctrl click.
> Cocooncrash reckons I should  examine
>  evdev, Option "ButtonMapping" and edit xorg.conf
> Whole bunch of technical detail to absorb, still thinking about it.
> I then tried what looked like a better option, installing mouseemu but 
> it did something horribly  weird to the keyboard.
> *
> *Since, dpkg-reconfigure has been deprecated I couldn't reset the 
> keyboard, so, I'm reinstalling again so my friend doesn't freak out, and 
> then I'll try mousetweaks.

One would think this would be a simple option in mouse preferences? 
Mousetweaks is installed by default in Karmic. Not sure how to configure.

The other option of editing xorg.conf seems unlikely since I tried to 
generate an xorg.conf file with this method:

Xorg -configure

System makes a file: /root/xorg.conf.new which, if it works, can be 
copied to etc/X11/xorg.conf

But in my case it bad. Xorg.conf is no longer around, so I'm a bit 
stumped. I've gone and asked a question at mouseemu to see if they know 

Ouch. The perfect Windows 7 installation is haunting me.


More information about the ubuntu-za mailing list