[ubuntu-za] Daemons no longer automatically starting viz apt-cacher-ng and cups

Chris Schoonbee cmschoonbee at mweb.co.za
Fri Feb 12 07:31:10 GMT 2010

Chris Schoonbee wrote:
> Hi all,
> I was wondering whether anyone had seen a similar problem (described 
> below) in the last two or three weeks.   I am also hoping that someone 
> can give me a clue as to how to fix it.
> Both apt-cacher-ng and cups printing had been working with no problems 
> for me since installation. But then suddenly the update manager started 
> complaining about not being able to connect to the repositories.  
> Aptitude showed the same problem when I tried to update manually.  I 
> tracked down the problem to being due to the apt-cacher-ng daemon not 
> running.  So I ran the command :
> sudo /etc/init.d/apt-cacher-ng start
> This sorted out the problem but I then found I had to rerun it after 
> every bootup whenever I wanted to use apt etc.
> I have not fiddled with anything so I thought an update might have 
> caused it and I was hoping that a later update would resolve it but that 
> has not yet happened.
> Then I encountered a similar with cups which made me think a more 
> general problem was occurring.  I had not used my printer over the 
> Christmas period but a few days ago encountered an error trying to 
> print.  I found out that no printers were "connected" (neither my 
> Brother nor my cups-pdf).  I discovered that cups was not running and 
> this reminded my of my problem with apt-cacher-ng.  So I used a similar 
> command
> sudo /etc/init.d/cups start
> and this resulted in the printers showing up again in the printing manager.
> But again I have to run this command every time after bootup.
> My Linux foo does not extend to knowing how to fix this permanently ie 
> make the programs start automatically again.  There may also be other 
> daemons that are not starting up anymore but that I am unaware of.
> Does anyone have any hints for me?  Or seen anything similar?
> Cheers,
> Chris
I found the reason for this behaviour - it was a bug in upstart 
0.6.3-11. Downgrading to 0.6.3-10 fixed my problem. Here is the bug 
report in case anyone else is seeing this behaviour:


More information about the ubuntu-za mailing list