[ubuntu-za] apt-cacher

Stefan Lesicnik stefan at lsd.co.za
Tue Sep 29 10:42:35 BST 2009

> I got apt-cacher up and running on my laptop and changed the the
> sources.list files on the new machines to refer to my laptop, e.g.
> "deb jaunty main
> restricted"
> I also had to change the apt-cacher.conf file to state:
> "offline_mode=1", to prevent it from trying to connect to the
> "non-existing" internet connection when the client machine makes a
> request.
> So no the client connects when I run "sudo aptitude update", but first
> of all it seems to ignore all the files on my laptop repository:
> Ign juanty Release.gpg
> Ign juanty Rranslation-en_ZA
> ...
> Then that is followed by errors:
> Err jaunty/main Packages
>   403 Sorry, not allowed to fetch that type of file: Packages
> Err jaunty/main Sources
>   403 Sorry, not allowed to fetch thta type of file: Sources


Im not exactly sure what you have got, but I have the following:

Firstly, i would say use apt-cacher-ng (seems to be later and worked
alot better for me)

apt-cacher - Caching proxy for Debian package and source files
apt-cacher-ng - Caching proxy for distribution of software packages

Once it is setup, modify your sources to be something like

deb http://aptcacher.lsd.co.za:3142/za.archive.ubuntu.com/ubuntu/
karmic universe

where aptcacher.lsd.co.za is the apt-cacher server and 3142 is the default port

Hope this helps somewhat


More information about the ubuntu-za mailing list