[ubuntu-za] dpkg returned an error code (1)

Lee Sharp leesharp at hal-pc.org
Wed Dec 16 15:10:07 GMT 2009


David Robert Lewis (ethnopunk) wrote:
> 
> Lee Sharp wrote:
>> David Robert Lewis (ethnopunk) wrote:
>>   
>>> Hi Wez,
>>>
>>> Thanks. I couldn't remove mxit-libpurple. Aptitude was stuck in a 
>>> puzzle.  First solution didn't work. Tried second solution. Had to 
>>> downgrade the package then upgrade. All fine now. Would you call this a 
>>> bug on the MixIt side? They obviously writing code in complete isolation 
>>> from Pidgin?
>>>     
>> I have been seeing a lot of these dependency problems the last few 
>> months...  There is a bug, but I am not sure where.
>>
>> 			Lee
>>
>>   
> A visualizer or some way to graphically see what is going on in the 
> system might help us solve these dependency problems. It's probably a 
> bug in dpkg.

I can see it in Synaptic.  In Update Manager or "apt-get upgrade" it 
will fail, and in Synaptic it will remove and add the same package 
rather than upgrade.  I have seen this several times.

			Lee



More information about the ubuntu-za mailing list