Scanner no longer works with my AMD PC

Nils Kassube kassube at gmx.net
Wed Mar 2 15:04:39 UTC 2016


David Fletcher wrote:
> On Wed, 2016-03-02 at 15:09 +0100, Nils Kassube wrote:
> > David Fletcher wrote:
> > > On Wed, 2016-03-02 at 14:06 +0100, Nils Kassube wrote:
> > > > It could be a problem with your USB cable. For my own scanner
> > > > (LIDE
> > > > 210) I have one USB cable which works and another USB cable
> > > > which
> > > > doesn't work (this one came with a card reader).
> > > 
> > > Thanks for the suggestion, but that was the first thing I tried.
> > > Plus
> > > another cable just now, just for good measure. Same result.
> > > 
> > > Is your scanner plugged into an Intel chipped USB port, or
> > > somebody
> > > else's?
> > 
> > Yes, mine is an Intel port.
> 
> OK that's consistent between yours and mine.
> 
> Question:- Do you have any other USB ports on expansion boards which
> will be non-Intel that could be tried, or is it a laptop that you're
> using?

This was on my desktop which only has Intel ports.

But out of curiosity I just tried it also on my old laptop (only Intel 
ports). On that machine it didn't work though, i.e. xsane first tried to 
scan and it sounded very choppy. After a while it stopped working with 
an I/O error message. The laptop runs 16.04 (32 bit) while my desktop 
runs 14.04 (64 bit). This was the first time I tried the scanner with 
16.04.

As I don't remember if I had used the scanner with the laptop before, I 
also tried it with 14.04.3 from my USB stick. There the scanner worked 
flawlessly with xsane. So there could be a problem with the 16.04 
version of xsane. Which Ubuntu version did you use on your desktop?

Finally I also tried it with my newer laptop (only Intel ports) which 
also runs 16.04, but the 64 bit version. There it worked, but it also 
ran a bit choppy and it was louder compared to my desktop. Again I tried 
it with 14.04 from my USB stick and the sound was the same as I know it 
from my desktop.

Just another thought: I don't think that the USB port controller would 
make a difference because xsane doesn't program the USB controller on 
its own. Instead it uses usblib which is probably quite independent from 
the chip type.

Nils




More information about the ubuntu-users mailing list