boot issues after restoring a backup

Juan Blanco intuitionist at
Mon Jun 29 17:40:24 UTC 2015

Hello Petter,I just solved an analogous issue.  I installed ubuntu 15.04 on /sdc and Debian 8.0 on /sdd.  After choosing /sdd5 as root partition to install grub on (several tries using different partitions none worked.)  I realized, after some reasoning that grub is looking for a previously installed grub partition, so after performing a clean install of Debian 8.0 on /sdd and as I was performing the last steps, I was asked to choose where to install the grub file, and I chose /sdc where I know ubuntu 15.04 is booting fine.  Voila!!  After rebooting, there it was the boot menu Debian on top and ubuntu below it.I have an another hard drive WD500 SATA where I am running Windows 10 TP _ 10130 build, so there is another entry for Windows which does not work.  No big deal, I just change my First boot device to that WD500 SATA and voila!!, there is Windows booting up.  All os'es are printing alright and have access to the internet.  You can always another hard drive.
Good Luck!,
> To: ubuntu-users at
> From: scar at
> Subject: Re: boot issues after restoring a backup
> Date: Mon, 29 Jun 2015 10:09:34 -0700
> Petter Adsen wrote on 06/29/2015 05:30 AM:
> > What's in /etc/fstab and /etc/crypttab? The output of lsblk and blkid
> > would also be useful in figuring this out.
> i don't understand why that would matter right now, as i can't even boot
> the kernel to the point where it asks for my passphrase and thus unlock
> the root partition with /etc/fstab and /etc/crypttab, but here is the
> requested info for sdb:
> i did try to update the files with the right UUIDs but i must be missing
> something....
> i'm thinking i should just do a fresh install of 12.04 and then after
> that is booting fine just restore my / (root) from backup... but that
> will revert /etc/fstab and /etc/crypttab too....
> -- 
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list