Gedit - disabling "untitled document 1"

Gene Heskett gheskett at wdtv.com
Thu Jan 29 13:29:55 UTC 2015


On Thursday 29 January 2015 03:52:56 rikona did opine
And Gene did reply:
> Hello Karl,
> 
> Wednesday, January 28, 2015, 10:33:59 PM, Karl wrote:
> > On Wed, 2015-01-28 at 21:50 -0800, rikona wrote:
> >> I've gotten quite irritated with Gedit - every edit generates a tab
> >> with "untitled document 1" that has to be dealt with on closing.
> >> How can I keep gedit from ever coming up with "untitled document 1"
> >> unless I tell it to. Net searching did not offer clues, but maybe I
> >> asked the wrong thing...
 
Hi Rikona, long time no see on the OT list. Scrap gedit, I have had it 
totally trash the contents of what are basically 7 bit ascii files 
entirely too many times.  So while we don't have the specialty code 
plugins for geany that gedit has, I switched to it for my linuxcnc work 
about 6 months back after gedit played mix-n-match for the 5th time on a 
nearly 500 line .hal file.

You don't play with or trash a configuration file for a machine with 
enough power to kill when you only wanted to scale a value for one 
function.  Or fix a damned typo because I can't type.  That's un-
forgivable.

> > Please describe in excruciating detail exactly how you are starting
> > gedit.
> 
> Mostly, I right-click on a file in konq and select "Open with gedit".
> 
> > I can only get an empty tab (one with "Untitled Document 1" or
> > similar as its name) in many different ways:
> > 
> > - if gedit is in my task bar (the Unity column of icons at far left
> > of the screen), by choosing any of "Open a New Window", Open a New
> > Document" or "Text Document".
> > 
> > - if gedit is in my task bar, by middle clicking it (or left clicking
> > it, if no gedit instance is currently running).
> > 
> > - starting gedit from the application finder
> > 
> > - clicking the "new file" icon in an existing gedit window
> 
> - selecting "File ->> New" from the menus in an existing gedit window
> 
> > - running gedit from the command line with no file argument
> 
> That's a lot of ways to get it... :-))
> 
> > I wonder if your gedit invocation has "--new-document" in it? You can
> > find out starting gedit however you are starting it, then running
> > this
> > 
> > command in a terminal window:
> >    ps ax | grep gedit
> 
> tried an experiment--
> 
> if from konq, I get:
> .... /usr/bin/gedit   plus   what file name was opened-
> opens with "untitled document 1"
> 
> if from Nautilus, I get:
> ....   what file name was opened, not preceded by
> /usr/bin/gedit  - so there is a difference in how it's called-
> opens without "untitled document 1"
> 
> - and  in both cases, a second line:
> grep --color=auto gedit
> 
> How can I NOT get "untitled document 1", preferably on a permanent
> basis, if I'm opening an existing file from konq, which I use most of
> the time?
> 
> Tried a few more ways to open it - opens with "untitled document 1",
> as you said, but closes without the extra, unneeded "save?" sequence -
> it just closes if no changes were made. If "untitled document 1" were
> there but added nothing extra to the close, that would be OK too.
> 
> Thanks for the comments...


Cheers, Gene Heskett
-- 
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
US V Castleman, SCOTUS, Mar 2014 is grounds for Impeaching SCOTUS



More information about the ubuntu-users mailing list