problem with cryptkeeper (2nd time)

Colin Law clanlaw at
Mon Nov 12 12:10:51 UTC 2012

On 12 November 2012 11:59, Joep L. Blom <jlblom at> wrote:
> Last Thursday (9-11-2012) I posted a letter requesting help with an urgent
> problem I have with cryptkeeper. After upgrading from 10.04 to 12.04 it
> won't open my encrypted file,containing all my sensitive information
> (keycodes, passwords, etc.) but comes with an error:
> "terminate called after throwing an instance of 'std::runtime_error".
> Up till now nobody reacted so I presume nobody has a clue how to solve this.
> As cryptkeeper is an official Ubuntu package, I thought to expect that
> somebody on this list could give a hint in what direction I have to look or
> give another solution to decrypt the file.
> I have tried gpg and ccrypt but to no avail. I have mailed the author but
> until now I haven't had any reaction.
> Hopefully somebody can shed some light on this (for me) urgent problem.

Not a solution for your underlying problem, but if you are stuck, and
since you were able to access it under 10.04, you may be able to
access the data by booting off a 10.04 live CD/USB.  If this works it
might be informative to know whether you can access it booting off a
live 12.04 image.

I presume you have tried decrypting a previous backup of the file
using your upgraded system.

Also it might be worth logging on as a different user to decrypt it in
case it is something in your user settings that has gone awry, though
that does not look likely.


More information about the ubuntu-users mailing list