Mounting USB Floppy Drive in Lucid

Graham Watkins at
Sun Dec 18 11:08:18 UTC 2011

Hi folks,

I'm having an issue when trying to mount my USB floppy drive.  At first 
when I plugged it in, it wouldn't mount at all.  I tried it on a Windows 
computer and it worked fine so it's not broken.

I then tried installing usbmount which worked, but changed all the 
permissions on devices and their files to root - not only on the floppy, 
but on usb flash drives as well, so I uninstalled that.

Mounted it from the command line with:

sudo mount -t vfat /dev/sdg /media/usbfloppy -o 

This showed the correct permissions for files, however when I tried to 
unmount it, I got the message:

umount: /media/usbfloppy is not in the fstab (and you are not root)

I have to either run nautilus as root or run sudo /umount/usbfloppy from 
the command line to unmount.

Is there any fix which will enable me to mount and unmount this drive 
without faffing about on the command line?

I posted about a similar problem back in 2010 when someone suggested 
holding the udisks package back to
1.0.1-1build1(lucid) which I did and it worked at the time but although 
the package is still held, it's not working now.



More information about the ubuntu-users mailing list