Mounting USB Floppy Drive in Lucid

NoOp glgxg at
Tue Dec 20 03:21:46 UTC 2011

On 12/18/2011 03:08 AM, Graham Watkins wrote:
> Hi folks,
> I'm having an issue when trying to mount my USB floppy drive.  At first 
> when I plugged it in, it wouldn't mount at all.  I tried it on a Windows 
> computer and it worked fine so it's not broken.
> I then tried installing usbmount which worked, but changed all the 
> permissions on devices and their files to root - not only on the floppy, 
> but on usb flash drives as well, so I uninstalled that.
> Mounted it from the command line with:
> sudo mount -t vfat /dev/sdg /media/usbfloppy -o 
> uid=1000,gid=1000,utf8,dmask=027,fmask=137
> This showed the correct permissions for files, however when I tried to 
> unmount it, I got the message:
> umount: /media/usbfloppy is not in the fstab (and you are not root)
> I have to either run nautilus as root or run sudo /umount/usbfloppy from 
> the command line to unmount.
> Is there any fix which will enable me to mount and unmount this drive 
> without faffing about on the command line?
> I posted about a similar problem back in 2010 when someone suggested 
> holding the udisks package back to
> 1.0.1-1build1(lucid) which I did and it worked at the time but although 
> the package is still held, it's not working now.
$ apt-cache policy udisks
  Installed: 1.0.1-1build1
  Candidate: 1.0.1+git20100614-3
  Version table:
     1.0.1+git20100614-3 0
        500 maverick/main i386 Packages
 *** 1.0.1-1build1 0
        100 /var/lib/dpkg/status

still works for me:
/dev/fd0 on /media/floppy0 type vfat (rw,nosuid,nodev,user=<>)

But I have the floppy in fstab:
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
so that may be the difference.

More information about the ubuntu-users mailing list