No easy mounting of nfs shares (Maverick)

Thierry de Coulon tcoulon at
Mon Oct 4 10:24:29 UTC 2010

On Monday 04 October 2010, Tom H wrote:
> Try adding your nfs mount to your fstab with "noauto" (and "user") and
> add "disk mounter" to your panel.

thanks. I tried that, but the share does not appear in disk mounter. My fstab 
line reads:

<ip address>:/<share>   /<mountpoint>  nfs noauto,users,exec,rw  0 0

Is there any other magic to do?

On Monday 04 October 2010, Jordon Bedwell wrote:
> On Mon, 2010-10-04 at 00:28 +0200, Thierry de Coulon wrote:
> > I've set up 10.10 (RC as far as I know), I tried autofs to mount network
> > shares but it does not seem to work (the mount points specified in
> > auto.master are not created, ans reloading or restarting autofs does not
> > help.
> And what do the logs say?

I would tell you if you tell me where they are. I googles for this and got 
different hints, but none where I could find anything about autofs.

> Because it's not hard to mount NFS manually with NFS-Common, example:
> sudo mount /usr

I know that and I do it, it works.

> If you're having so much trouble with AutoFS just create a static mount
> and then edit ~/gtk-bookmarks and add the mount point, an example of
> doing this would be:
> FSTAB: /mnt/shared nfs rw,hard,user,intr 0 0
> Bookmark: file:///mnt/shared

I tried that but where is it supposed to show? I get nothing in Places, but 
that might be because I don't use "hard" mounting (I can't as the shares are 
not allways available (no central server runnniong 24/24).

> Don't know if you noticed, but this isn't Mac OS X, this also isn't KDE.
> > nfs being the logical *nix choice for a network, it's surprising that
> > Linux distribution make it so difficult for the users to use it...
> Was this serious or a troll? You pick up an RC build that is still going
> through it's final major bug fixes and then complain about trivial
> problems? Why are you going to *test* software if you're going to
> complain it's broken?  The best thing for you to do is gather a trace,
> view the logs and then decide if you need to submit a bug.

No need to be aggressive. No, it's no troll. And I am *not* criticizing either 
Ubuntu or Maverick RC. I picked it because I have relatively new hardware and 
Maverick picks up all of it (ethernet, wifi, card reader, webcam) where other 
ditributions/releases don't. I am fully aware it's an RC. I am not familiar 
with Ubuntu and Gnome, so I don't know if things may be bugs or not. As far 
as I can say Maverick is terrific even as it is (RC), so much that I am 
seriously considering switching to it.

Besides, it's nothing new to Maverick that starting a search for "network" 
shows you samba shares (if any) but not nfs shares. And it's not Ubuntu 
specific either. The question (which is a general question) is why there is 
no GUI tool that will list nfs servers and shares, which I would expect to 
be "normal" servers and shares in Linux environment.

The reference to KDE and MacOS X was just to say that in MacOS X it's easier 
to connect to an nfs server (through the GUI) than it is in Gnome (as far as 
I can tell, but I'd be delighted to learn I'm wrong).

KDE 4 dropped and screwed that feature, which leaves me with the option to try 
Ubuntu+Trinity, or to try and see if I can setup Gnome to do what I need. It 
seems to me that autofs does not work on "my" Maverick install, so before I 
would "complain" and fill a bug repport I use the mailing list to check if 
maybe I did things the wrong way (so if someone says autofs works for him in 
Maverick I could ask how he did).

If it's forbidden on this list to issue any statement/question that does not 
imply that Ubuntu <add-your-version-here>  is the greatest of all operating 
systems in the Galaxy I'd probably better unsubscribe as fast as I can...

Oh, and (to all that read this) please don't start a big flame war about what 
I just said - my question was about finding a good way to mount/umount nfs 
shares on the GUI (once set up, the KDE 3 desktop made this possible with one 
mouse click, so I'm a little unhappy to have to use the command line or write 
scripts because I'm a lazy guy :)


"We live at a time when emotions and feelings count more than truth, an there 
is a vast ignorance of science" James Lovelock

More information about the ubuntu-users mailing list