No easy mounting of nfs shares (Maverick)

Tom H tomh0665 at
Mon Oct 4 00:23:49 UTC 2010

On Sun, Oct 3, 2010 at 6:28 PM, Thierry de Coulon <tcoulon at> wrote:
> I am new to Ubuntu (but not to Linux) and to Gnome (used to use KDE before 4
> was forced on me).
> I've set up 10.10 (RC as far as I know), I tried autofs to mount network
> shares but it does not seem to work (the mount points specified in
> auto.master are not created, ans reloading or restarting autofs does not
> help.
> Now my actual question is: why does "Places/Network access to Windows shares
> (Windows Network), of which I have none, but can't access nfs shares? In the
> same way, "Connect to server" offers anything but acces to nfs servers
> (unless it is though "Custom Location" and I could not find the right syntax
> (I get "You must enter a name for the server" whatever I try).
> I have no problem connecting to the servers from MacOS X, and I had no problem
> doing it from Desktop links in KDE 3. KDE 4 let's me create the link but, as
> usual, it does not work ("only root can do that").
> nfs being the logical *nix choice for a network, it's surprising that Linux
> distribution make it so difficult for the users to use it...

You might be blaming the wrong "people." If you tried Debian's or
Fedora's GNOME edition, you'd probably want to change the above to
`'it's surprising that a Linux DE makes it so difficult for users to
use" nfs...

Try adding your nfs mount to your fstab with "noauto" (and "user") and
add "disk mounter" to your panel.

More information about the ubuntu-users mailing list