"dpkg was interrupted" - how to fix it

J dreadpiratejeff at gmail.com
Tue Feb 16 04:09:45 UTC 2010

On Mon, Feb 15, 2010 at 22:27, Thomas Blasejewicz <thomas at s7.dion.ne.jp> wrote:
> I tried Ctrl+Alt+F2 -> that did transport me into outer space - a place
> I did understand even less and then was not able to leave any more.
> I tried entering the commands you suggested again, with or without
> spaces before the "-" and all other possible variations I can think of
> etc., but I could not make anything work yet.

No worries... welcome to the soup.

First of all, Ctrl-Alt-F2 takes you to a console.  In reality, your
GUI is ALSO a console, just one that happens to be running a GUI
environment.  This, after all, ain't windows ;-)

To get back, remember this:  Ctrl-Alt-F7 is the console that the GUI
runs on. (some of the newer Linuxes are running it on F1, so keep that
in mind).  But for fun, try that out for a bit... just cycle through
them and see what you find.  Ctrl-Alt-F(1 - 7)

However, that's not really important at the moment.  Everything you
need to do you can do from within the GUI by running a terminal (the
terminal is the GUI application that gives you a command line
interface.  Think of it similar to running cmd.exe or the "dos prompt"
on a Windows system).

If I understand you correctly, you WERE able to log in successfully to
the console.  As an aside, however, if you run a Terminal inside the
GUI, you won't have to log in...

so you run those commands exactly as I typed:

sudo dpkg --configure -a
sudo apt-get -f install

I don't know exactly what, if any, output you will get, but in theory,
you should be able to run those, and then redo your update.

When you run the first command, you should be prompted to enter your
password like this:

dreadpiratejeff at asuka:~$ sudo dpkg --configure -a
[sudo] password for dreadpiratejeff:
dreadpiratejeff at asuka:~$

I got no output, however, I also don't have any broken packages and
I'm not sure how to fake a broken package install to recreate this
problem you've got.

When you run the second command, you shouldn't have to use a password
(assuming you've run it within a certain amount of time after the
first command).

Again, with the apt-get command, I'm not sure what, if any, output you'll get.

What you CAN do, I believe is run the commands like this:

dreadpiratejeff at asuka:~$ sudo dpkg --configure -a
[sudo] password for dreadpiratejeff:
Sorry, try again.
[sudo] password for dreadpiratejeff:
dreadpiratejeff at asuka:~$

> Probably this thread is already annoying to a lot of people, so if there
> would be one person willing to talk me through this ... I would be
> eternally grateful
> I am afraid, that person would also have to be extraordinary patient,
> because, frankly all the well-meant advice and instructions sound to me
> like some ancient egyptian, hieroglyphic talk I am unable to follow.

Nonsense.  Well, I can't guarantee this isnt annoying someone, but
this is the internet.  And this is, as far as I am concerned, EXACTLY
what this list exists for.  I'm just hoping that someone more in tune
with dpkg and apt-get will jump in here and offer some advice, because
I'm not as well versed in dpkg issues as I am in RPM (another type of
packaging, used by other Linux distributions like Red Hat and SuSE).

In any case, regardless of whether anyone gets annoyed and whines,
keep asking and keep trying and keep learning.  You're doing well so
far, and we all have to start somewhere :-)




Samuel Goldwyn  - "I'm willing to admit that I may not always be
right, but I am never wrong." -

More information about the ubuntu-users mailing list