"dpkg was interrupted" - how to fix it

J dreadpiratejeff at gmail.com
Tue Feb 16 02:14:19 UTC 2010

On Mon, Feb 15, 2010 at 20:54, Thomas Blasejewicz <thomas at s7.dion.ne.jp> wrote:

> E: dpkg was interrupted, you must manually run
> 'sudo dpkg -- configure -a' to correct the problem.
> E:_cache -> open() failed, please report.
> I DO NOT understand what is meant by that and what I am supposed to do.
> I tried Alt+F2 and there enter 'sudo dpkg -- configure -a' (whatever
> that means).
> As far as I can tell nothing changes/happens. I tried to modify that
> command by referring to a number of guidebooks.
> Yet, so far still nothing happens AND the error remains.
> HOW am I supposed to correct this error?
> And what "exactly" am I supposed to enter where?

This may be a very basic question, but... when you dropped to console
(when you hit alt-F2) did you actually log in?
sudo dpkg -- configure -a
You'd pass your username and then password, and after you get logged
in and get a prompt, you pass that command.

Also, you can just open a terminal from within the GUI.

I haven't had to do this, though I've seen plenty of cases where
running dpkg --configure fixes the world's ills (not literally, but
it's a first step to fixing dpkg issues...)




Marie von Ebner-Eschenbach  - "Even a stopped clock is right twice a
day." - http://www.brainyquote.com/quotes/authors/m/marie_von_ebnereschenbac.html

More information about the ubuntu-users mailing list