"dpkg was interrupted" - how to fix it

Thomas Blasejewicz thomas at s7.dion.ne.jp
Tue Feb 16 01:54:25 UTC 2010

Yesterday I was starting up the notebook PC I am using to experiment
with Ubuntu.
It is hooked up to an AC adapter.

Boot went uneventful.
Update manager told me, there are new updates -> so I chose to install them.
DURING that process - for reasons I do not know (maybe the AC adapter
came loose, but it does not look like it) - the PC suddenly shutdown =
like the power were cut.

After I rebooted the PC and tried to do the update
AND wanted to use Synaptic to install new software, I got the following
error message:

E: dpkg was interrupted, you must manually run
'sudo dpkg -- configure -a' to correct the problem.
E:_cache -> open() failed, please report.

I DO NOT understand what is meant by that and what I am supposed to do.
I tried Alt+F2 and there enter 'sudo dpkg -- configure -a' (whatever
that means).
As far as I can tell nothing changes/happens. I tried to modify that
command by referring to a number of guidebooks.
Yet, so far still nothing happens AND the error remains.

HOW am I supposed to correct this error?
And what "exactly" am I supposed to enter where?

Thank you.

More information about the ubuntu-users mailing list