[ubuntu-users] Confused over CIFS

Matthew Flaschen matthew.flaschen at gatech.edu
Sun Jan 11 02:23:22 UTC 2009

Ted Hilts - Thunderbird Acct. wrote:
> I did the following on the Ubuntu machine called "Ubuntu"

What version of Ubuntu?

> Part way through it got very slow -- and I mean very slow!!!

SMB is not really designed to transfer huge amounts of data.  It's
better to use rsync for that (there are Windows rsync servers), as
you'll get better compression.

> So I decided to <CTL C> , then I tried under another session using the 
> command "sudo smbumount /Mted-misty"

Cancelling the copy should not have removed your mount.  It was a
mistake to remount, especially on the same mount point (/Mted-misty).

> and checked the mount state which showed /Mted-misty as still mounted but as a CIFS mount.

This is a little bit confusing.  SMB and CIFS are basically the same
thing, but there are multiple filesystem drivers designed to let you
mount them.  On Hardy at least, smbmount is a symbolic link to
/sbin/mount.smbfs , but nonetheless resulted in a cifs mount when I tested.

  New to me so I
> checked the man facility which told to use "umount.cifs" which did not 
> work.

You usually need to give the arguments when talking about a command.
Otherwise, it's really impossible to know what you did.  I did a test mount:

smbmount //***.***.***.***/USER /home/matthew/test/smb_mount -o

(the stars are private data)

It worked (albeit quite slowly).  I then successfully unmounted with:

umount.cifs /home/matthew/test/smb_mount

> The CIFS protocal automatically engaged was not expected so I researched it.

I don't see any automatic engagement here.  You told it to mount, so it
did (which obviously requires communicating using CIFS)

> How should I do this data transfer?

Again, use rsync for large transfers.

Matt Flaschen

More information about the ubuntu-users mailing list