[ubuntu-users] Confused over CIFS

Preston Kutzner shizzlecash at gmail.com
Sun Jan 11 04:08:38 UTC 2009


On Jan 10, 2009, at 8:23 PM, Matthew Flaschen wrote:

>> Part way through it got very slow -- and I mean very slow!!!
>
> SMB is not really designed to transfer huge amounts of data.  It's
> better to use rsync for that (there are Windows rsync servers), as
> you'll get better compression.

Just out of curiosity, what is your reasoning that SMB is not designed  
for transferring huge amounts of data?  SMB/CIFS is the file sharing  
protocol Microsoft uses in its Windows operating system.  It is  
designed, in a sense, as Microsoft's alternative to NFS.  If it wasn't  
meant for large transfers of data, it wouldn't be the primary protocol  
for file-sharing in Microsoft solutions.

>
>
>> So I decided to <CTL C> , then I tried under another session using  
>> the
>> command "sudo smbumount /Mted-misty"
>
> Cancelling the copy should not have removed your mount.  It was a
> mistake to remount, especially on the same mount point (/Mted-misty).
>
>> and checked the mount state which showed /Mted-misty as still  
>> mounted but as a CIFS mount.
>
> This is a little bit confusing.  SMB and CIFS are basically the same
> thing, but there are multiple filesystem drivers designed to let you
> mount them.  On Hardy at least, smbmount is a symbolic link to
> /sbin/mount.smbfs , but nonetheless resulted in a cifs mount when I  
> tested.
>
>  New to me so I
>> checked the man facility which told to use "umount.cifs" which did  
>> not
>> work.
>
> You usually need to give the arguments when talking about a command.
> Otherwise, it's really impossible to know what you did.  I did a  
> test mount:
>
> smbmount //***.***.***.***/USER /home/matthew/test/smb_mount -o
> user=****,pass=****
>
> (the stars are private data)
>
> It worked (albeit quite slowly).  I then successfully unmounted with:
>
> umount.cifs /home/matthew/test/smb_mount

You really should make sure you have at least samba-client and smbfs  
installed.  Then, use the following command to mount your share from  
your Windows XP box:

sudo mount -t cifs //<windows_machine>/<share> /<mount>/<point> -o  
username=*****,password=*****

You can add "uid=<your_uid>,gid=<your_gid>" to the end of that to make  
sure the files are mounted with the ownership permissions set to you.   
When you want to unmount, just do:

sudo umount /<mount>/<point>

>
>
>> The CIFS protocal automatically engaged was not expected so I  
>> researched it.
>
> I don't see any automatic engagement here.  You told it to mount, so  
> it
> did (which obviously requires communicating using CIFS)
>
>> How should I do this data transfer?
>
> Again, use rsync for large transfers.

You can either try to find a Windows rsync "server" application, or  
use the above commands as I've suggested.  You shouldn't need to use  
smbmount or smbumount anymore, just mount umount with the -t cifs  
switch.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 194 bytes
Desc: This is a digitally signed message part
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20090110/ce6d5ee1/attachment.pgp>


More information about the ubuntu-users mailing list