Update Manager Hanging

NoOp glgxg at sbcglobal.net
Wed Oct 29 20:28:13 UTC 2008

On 10/29/2008 08:22 AM, Kipton Moravec wrote:
> I have not had any problems with update manager until about two weeks
> ago.
> It would hang and say it was downloading, and nothing would happen. I
> could leave it for an hour and still no change. Finally I would kill the
> process and restart and sometimes it would go and sometimes hang
> again.  
> One time I had to do the check button first, then the install would work
> fine.
> Today I tried the check and it is hanging during the check. According to
> the system monitor the process is sleeping. Memory is 459.1 MB out of
> 1.5GB and Swap is 0 out of 453 MB. The network is < 1 kb per second so
> it is not because the computer is overloaded.
> When it hangs it is before it asks for the password.
> This time I had to try 3 times before it finally worked. Any Ideas?

If it is hanging before the password then it probably is related to this:

[ update-manager fails to bring up the password prompt for root
privileges] Warning, it's a long read.

Can you post the output of:

cat /etc/hosts

Try running from the terminal first:

sudo apt-get update
sudo apt-get upgrade

See if you notice any sources errors of the first one. On the second,
you should see errors if any of the packages are not upgrading properly.

More information about the ubuntu-users mailing list