Restore latest kernel

Mike Adolf mlnx at
Thu Oct 16 20:57:25 UTC 2008

Derek Broughton wrote:
> Mike Adolf wrote:
>> I can not boot 
> OK, in the first place you said both "latest" and "" (which is
> hardly "latest", but is probably the most recent in hardy).  Please try to
> be precise, because if you really put this module into, it's no
> surprise it isn't working.
>> If I boot it in recovery mode it gets to the 
>> point of running modprobe and gives the error "abnormal exit" and hangs.
>> Recovery mode boot flies by so fast I can't really see what it is doing.
>> I can still boot into a previous kernel (.19)
> So boot into the old kernel, and remove the driver you just built.  "depmod"
> needs to be run again before booting into the new kernel, but I believe
> it's done automatically.
> Have you actually tried using the new kernel with the original driver?  It
> may seem like a stupid question, but I can't believe the number of people
> who load a new kernel and compile drivers because they saw something on the
> always trustworthy Internet that told them to do it, without ever checking
> whether the existing drivers did the job.
Yes, I tried tvtime which was working with an older tv wonder analog 
only card. I don't get any errors just a black screen. All the controls 
function but don't change anything.

dmesg gives:
[ 62.125469] cx88[0]: TV tuner type -1, Radio tuner type -1
[ 62.470270] cx88[0]: TV tuner type -1, Radio tuner type -1
[ 62.678501] tuner: disagrees about version of symbol tea5767_attach
[ 62.678504] tuner: Unknown symbol tea5767_attach
[ 62.678592] tuner: Unknown symbol tda8290_probe
[ 62.678629] tuner: Unknown symbol tda8290_attach
[ 62.678796] tuner: disagrees about version of symbol simple_tuner_attach
[ 62.678798] tuner: Unknown symbol simple_tuner_attach
[ 62.678824] tuner: disagrees about version of symbol microtune_attach
[ 62.678826] tuner: Unknown symbol microtune_attach
[ 62.678931] tuner: disagrees about version of symbol tea5761_attach
[ 62.678933] tuner: Unknown symbol tea5761_attach

which doesn't tell me much. If Ubuntu thinks the chip is cx88, it's not. 
The chipset is cx23883-39. Maybe cx88 is a family? Anyway, I'll google 
around and see if I can find some info other than that on mythtv.

Thanks for your reply,

More information about the ubuntu-users mailing list