8.04 Upgrade Failure - tzdata (and many others)

Bill Moseley moseley at hank.org
Mon May 5 15:02:46 UTC 2008

On a Thinkpad T60p / ATI FireGL / Atheros AR5418 wireless.
Everything worked (wireless, compiz, sound), except sleep/hibernate
which was a know problem on these machines.

Upgrade from up-to-date Gutsy failed miserably.

At upgrade tzdata was the only package not to install:

 unable to make backup link of `./usr/share/zoneinfo/America/Atikokan'
 before installing new version: Operation not permitted

Then I tried to reboot:

1) upon reboot I was sent to a shell prompt and told to run fsck.
fsck reported many bad blocks.  I had run fsck before the upgrade and
have never seen any problems.  Not sure if the upgrade could have
caused that or if fsck is reporting wrong.

2) rebooted again and skipped fsck.  Xorg started but could not log
in.  Had to disable xserver-xgl.

3) Was able to log into Gnome desktop.  Very little works.  Left-click
on panel icons does not run them but instead shows the move icon.
Gnome menus do not work correctly.

4) Wireless does not work anymore.

5) Can't ctrl-alt-del to bring up shutdown menu (but that will freeze
the desktop).

Pretty rotten upgrade.

Any of those failures sound familiar?

Is it worth trying to fix or is it time for a clean install?

Bill Moseley
moseley at hank.org

More information about the ubuntu-users mailing list