One Way Samba

Leonard Chatagnier lenc5570 at
Thu Feb 21 06:09:43 UTC 2008

--- NoOp <glgxg at> wrote:

> On 02/19/2008 06:33 AM, Leonard Chatagnier wrote:
> > I can access the Lan and the other  PC shares from
> one
> > machine but not the other. They both have server
> and
> > client samba software installed. The computer from
> > which I can't access using nautilus is a 64 bit
> gutsy
> > on a brand new Gateway gt5656 but I now can mount
> it
> > via info from my last post and see the homes share
> on
> > the 32 bit machine. When I use nautilus on the 64
> bit
> > it only shows the 64 bit shares no matter what I
> do
> > when I try to connect to server. Using nautilus on
> the
> > old maching I was able to copy files from one to
> the
> > other, a first time for me.
> > Both machines have the same smb.conf. The old
> machine
> > is connected wirelessly.  Don't really know what
> info
> > to provide but happy to supply what's requested.
> > What I want to know is how to uses nautilus from
> the
> > 64 bit machine with the same success as I had on
> the
> > 32 bit machine. This is my first use of nautilus .
> > Appreciate any help, suggestions.
> > TIA,
> >  
> > 
> > Leonard Chatagnier
> > lenc5570 at
> > 
> I highly recommend closely reviewing:
> I also recommend assigning fixed IP's to your local
> machines & connect
> by IP address if you encounter problems. This will
> eliminate any
> dns/machine name/resolve problems you may encounter.
> If you find that
> you have no problems with connecting via a fixed IP,
> then you can go
> hunting for name resolution problems.
First this I did was to make the IP ADDR's static
using the gui's and what a headache. I use
KWifiManager, Network and Network Tools from
kubuntu-desktop. Couldn't connect on the wifi and
found that Network Tools was set to lo instead of
wlan0i, which I did, so I reverted to wlan0 and got on
line. There is no change; I can mount from the 64 bit
machine using IP but not machine name/host name. Also
can't access ubuntu using name or IP with dolphin or
nautilus as I did on ubuntu, so status is exactly the
same; no change.
Next, I started reading the complete(so called) guide
and following instruction; regretfully. Followed the
ubuntu section as not interested in Vista now. Added
the smb group(don't see that's needed but did as
instructed) and user. Proceeded the the "Test your
shares" section and could mount using the listed mount
cmd using IP but not ubuntu. Tried several times and
one time used the listed command:
sudo umount -a -t smbfs, which didn't work giving:
umount: /media/winshares: device is busy
Whereas, sudo umount /media/winshares give the output
twice. Right now, I can't unmount the
/media/winshares, period.
Did more exploring'testing and tried this cmd with
some strange output:
lchata at ubuntu64:/media$ sudo smbclient -L
session setup failed: NT_STATUS_LOGON_FAILURE
lchata at ubuntu64:/media$ smbclient -L ubuntu -U lchata
-W workgroup
Error connecting to (No route to host)
Connection to ubuntu failed (Error
lchata at ubuntu64:/media$
Note the IP in the dmd vs. the IP in the output? The
.64 IP in output was the old IP for the ubuntu maching
when it was wired and the .65 IP is the IP for the
same machine relocated with the wifi adapter setup.
Now where in gutsy is there a file that still has the
old IP ADDR for the machine when it was wired to the
2wire router/modem combo? IMHO, this is at the heart
of my problem. Although can't duplicate it, I've seen
the IP in the output using Network Tools.
Just now duplicated it again using Lookup "ubuntu"
internet addr which gave:
Source	TTL	Address Type	Record Type1	Resolution	0	IN	A	41728	IN	NS

Now, I don't know how to fix this or where to look and
would appreciate some guidance here. I'll stop with
the comprehensive guide until I get this cleared up
and if not my next step is likely to purge all of
samba and start over. Actually this was a fresh
install of samba due to fresh gutsy installs on both
comps. Hoping for some suggestions, except call ATT
DSL or 2WIRE, to fix the IP issue.

Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list