Printers on the network

Mark Haney mhaney at
Thu Dec 4 14:51:34 UTC 2008

Bart Silverstrim wrote:
> Occasionally I try printing a PDF and it appears to get "stuck" in the 
> queue, processing for 10, 20, 30 minutes or more, and then a 
> notification balloon appears in my top panel bar with the printer icon 
> telling me that the printer may be disconnected from the network or not 
> connected.

Does this only happen with PDFs?  And does it happen every time with 
PDFs?  Or is that 'occasionally' mean you can print PDFs okay more of 
the time, but not always?

> The printer still pings on the network, and it's happened with a couple 
> printers (although the most recent was using an HP LJ5000). I suspect 
> something has gone wrong with the rendering of the print job, but I'm 
> not finding the stuck process.

This sounds like the print driver doesn't like the format of that PDF. 
I've seen that happen before.  But it's pretty rare to see.

It's possible that the app you are trying to print from isn't even 
getting the print job to CUPS, which is why restarting it doesn't fix 
it.  I saw this with OOo on my laptop a while back. Never could figure 
out why, but upgrading to 3.0 fixed it.

> I tried "sudo /etc/init.d/cups restart", no error, but still won't print.
> Anyone else have a workaround or fix for this? Or even experience it? 
> Seems like a restart fixes the problem (and I'm doing a batch of 
> upgrades at the moment so I have to restart now anyway) but insight as 
> to what is happening would be appreciated.

I've had it happen (see above) before, but I have no answers.  I'm 
curious as to why you think you need to restart after doing updates? 
Unless it's a kernel update, I typically don't bother restarting until I 
need to.

Frustra laborant quotquot se calculationibus fatigant pro inventione 
quadraturae circuli

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

Call (866) ERC-7110 for after hours support

More information about the ubuntu-users mailing list