Trouble installing server

Jan Sneep jan at
Fri May 11 10:50:06 UTC 2007

> -----Original Message-----
> From: ubuntu-users-bounces at
> [mailto:ubuntu-users-bounces at]On Behalf Of Eamonn
> Sullivan
> Sent: May 11, 2007 2:41 AM
> To: jan at; Ubuntu user technical support,not
> for general
> discussions
> Subject: Re: Trouble installing server
> On 5/11/07, Jan Sneep <jan at> wrote:
> >
> >
> > I downloaded the 7.04 Server iso which made a boot-able CD
> and the install
> > seems to have worked, except that on the boot-up it hangs
> at "Running local
> > boot scripts (/etc/rc.local)" and goes no further. Just
> hangs there. If I
> > hit enter I can login with the user ID & Pswd that was
> created during the
> > install. But I'm stuck there.
> If I understand you correctly and you can log in, that's it, you've
> successfully installed the server version. That version doesn't
> install any graphical user interface (most servers don't have any). If
> you're looking for that, either install the desktop version to begin
> with or type:
> sudo apt-get update && sudo apt-get install ubuntu-desktop
> on your recently installed server.
> I have 7.04 server and it runs headless. I do all management through
> ssh, scripts, monitoring daemons that send me email, etc.
> It sometimes comes as a shock to people coming from Windows, but
> that's what most Linux servers look like. If you're brand new to
> Linux, I'd suggest starting with the desktop version and play around
> from there. All of the same server components are available. The only
> real difference is the kernel. The server version uses a kernel
> optimized for network services (like databases and Web servers), while
> the desktop kernel is aimed at making local applications more
> responsive.
> -Eamonn

Thanks, but even if there isn't a graphical interface, shouldn't the Login
prompt appear on it's own, without me having to hit enter?

How can I see the contents of rc.local to see what scripts it is trying to
run and would there be any error logs to look at to know that everything did
in fact boot properly? I tried old Dos commands like "edit rc.local" and
"gedit rc.local" and "type rc.local" and even "help" by itself and nothing
that I could think of would show me what is actually in the file.

Perhaps it is not hanging at the rc.local file, perhaps it is in the next
step? Is there some way to activate a verbose step-by-step boot so I can
specifically see what is happening?


More information about the ubuntu-users mailing list