Problem with ethernet

Bill Marcum marcumbill at
Thu May 10 15:40:13 UTC 2007

On Thu, 10 May 2007 10:13:44 -0400, Michael S. Peek 
  <peek at> wrote:
> Hello all,
> I have a laptop with both wireless and wired ethernet, and I'm having 
> some problems.  I'm hoping some kind soul here will know more than I and 
> can give me a hand.
> The wireless works fine.  Super.  Splendid.  But for large files, I 
> would rather be able to use the wire as it's faster.
> And the wired used to work, but doesn't anymore.  I have not tried it 
> since before I upgraded to Feisty.  My fear is that something has 
> changed in the kernel drivers, but I'm not knowledgeable enough to know 
> what to do about that.  (So I've included output from lspci and lsmod 
> below -- hopefully if that's the problem then someone will spot it and 
> send me a clue.)
> If I configure it to use a DHCP address then it comes back with an 
> address of  This is /not/ in an address range assigned by 
> our DHCP server, and of course, I can see nothing on the network.  So, 
> for the purposes of further testing, I abandoned DHCP and set up a 
> static IP for it.  But after configuring it to use the static address I 
> still can't see anything on the network.  (The first thing I tried was 
> pinging the gateway address.)
The 169.254 address probably comes from zeroconf.  This is a protocol 
that allows computers to set their own IP address in a network without a 
DHCP server. You should probably remove it if you don't intend to use 
it.  By the way, did you choose the static IP address, or did you get it 
from your ISP?

Laundry is the fifth dimension!!  ... um ... um ... th' washing machine
is a black hole and the pink socks are bus drivers who just fell in!!

More information about the ubuntu-users mailing list