locale not supported by Xlib

Roberto Nunnari roberto.nunnari at supsi.ch
Wed Nov 29 16:52:26 UTC 2006

Roberto Nunnari wrote:
> Hi Matthew.
> Matthew Kuiken wrote:
>> Roberto Nunnari wrote:
>> <snip>
>>> Roberto Nunnari wrote:
>>>> Hello everybody.
>>>> I'm evaluating Ubuntu 6.06.1 for installing on our clients
>>>> (about 35 hosts). Up to now, Ubuntu is in my opinion the best
>>>> linux distribution I ever tried.
>>>> Unfortunately, I hit a problem I cannot seam to be able to solve.
>>>> I noticed the problem first while trying to install Maple 10. The
>>>> installation program dies with an error 'locale not supported by Xlib'.
>>>> So, I tried to launch gedit, and guess what? Gedit works, but in the
>>>> shell I find the same message as above (cut and paste follows).
>>>> I probably broke something while installing other software by
>>>> hand (oracle, matlab, eagle, etc..).
>>>> I tried to reinstall some locales, to change the language,
>>>> reinstall xorg, but without success.. the messages are still there.
>> <snip>
>> I can only think of two things, and I'm not certain either will do 
>> anything for you.
>> First is to ask how you reconfigured the locales.  If you used 
>> locale-gen, then I don't have any other knowledge there.
> No. I didn't use locale-gen.. I just went to
> System -> Administration -> Language support
> and changed the default language.
> In the upper panel I see that the support tick is
> checked only for english and italian languages
> In the dropdown menu in the lower panel I chose
> English (Australia), which was the default after
> installing ubuntu. Before I had italian (Switzerland)
>> Second is that if you have re-installed all of those things, and still 
>> are seeing the error, it might be a setting in your user configuration 
>> files.  I would try either backing up your config files, and removing 
>> them all, or creating a new user to see if the problem exists on a new 
>> account.
> I'll try to create a new account and do some testing with it.
> Thank you for the hints. I'll let you know the results.

No luck. I created a new user and logged in with it, but
the problem is still there.

so.. it's not a user configuration problem, but a
global configuration problem..

Any more hints?

What are the packages I should reinstall?
What are the ways to reconfigure xlib?

Thank you.

>> This is the extent of my knowledge on this subject, so if these don't 
>> work, I hope that someone who knows more can chime in.
>> -Matt

               Roberto Nunnari -software engineer-
                mailto:roberto.nunnari at supsi.ch
  Scuola Universitaria Professionale della Svizzera Italiana
              Dipartimento Tecnologie Innovative
  Via Cantonale                        tel: +41-91-6108561
  6928 Manno                 """       fax: +41-91-6108570
  Switzerland               (o o)

More information about the ubuntu-users mailing list