Colony 4 install experience on Dell Inspiron 9300 - still wifi problems

Paul Rutter tomgarty at
Fri Sep 9 16:02:57 UTC 2005

(I am a bit of a newbie).

First, thanks to all the linux developers for a lot of work
and ever improving results.

My laptop is a Dell 9300, pretty vanilla version except a
WUXGA screen. It has the Intel "ipw2200" b/g wireless
chipset. Here is my "out of the box" fresh install

Download Colony 4 install iso image. Did md5sum check on it.

Burned iso image to disk. Ran "md5sum -c" check on all files.

Tried default boot. Got the usual, almost immediate, blank
screen and no further disk activity, had to force power off.
(Just thought I would try again, default has never worked on
any other linux attempt on this machine).

Tried "linux debian-installer/framebuffer=false"
This worked, including configuring ie1 with the name and WEP
key during installation. Installation completed successfully,
there where no ipw2200 error messages in dmesg after logging

Now the main problem: wifi does not work with firefox in any
useful way.

Here are the symptoms:

This is a dual boot machine. Wifi works fine under windoze
(sigh); signal strength is very high.

Wifi also did not work correctly for me under ubuntu 5.04 or
colony 3.

Wifi actually works somewhat. For example, I can download
updates via synaptic or the update manager (with occasional
hiccups). But trying to use firefox, it is almost always
impossible to get a web site to load, it usually hangs
forever with "contacting google" (or any other site) in the
firefox status line. Sometimes though, a page will load. With
my limited knowledge, it acts like opening any new ip address
is torture and likely to hang trying (after a long time,
there is an error message that it can not contact the site).

>From a bit of googling around, it appears that some folks are
getting ipw2200 to work on their Dell 9300s -- by rebuilding
the code pieces themselves. It seems though that the
successful combinations of pieces for this machine
configuration have not made it into ubuntu yet (or Fedora
Core 4), probably because the developers do not have both the
machine and wifi.

Are there any simple things I can try?  Will adding "no_apic"
to the boot line and re-installing help?  I am willing to
wait until 5.10, though I wonder if the fix will be in that?
(Lots of great stuff in ubuntu linux, if wifi was not my only
connection at the moment I would have already switched!)


Click here to donate to the Hurricane Katrina relief effort.

More information about the ubuntu-users mailing list