Colony 4 install experience on Dell Inspiron 9300 - still wifi problems

Vaibhav Vaidya ampfp at
Fri Sep 9 17:05:53 UTC 2005


I am typing this from Ubuntu on a 9300 connected with
wifi... :)
I have hoary though, not breezy. the initial install
of ipw had some hiccups, my ipw used to conk off after
20 mins. So I went to
and downloaded the ipw2200 driver (1.0.6),
corresponding  firmware and the 80211 ieee libraries.
I copied the firmware into /lib/hotplug/firmware/,
compiled the 80211 driver, compiled the ipw driver,
used the unload script from ipw to remove previous
versions from my system, inserted the 80211 module and
finally inserted the ipw module. Read the readme files
for both drivers, and you should be fine. Note: Wifi
LED doesnt work, Fn+F2 works silently.

This is a good site for ubuntu on linux

--- Paul Rutter <tomgarty at> wrote:

> (I am a bit of a newbie).
> First, thanks to all the linux developers for a lot
> of work
> and ever improving results.
> My laptop is a Dell 9300, pretty vanilla version
> except a
> WUXGA screen. It has the Intel "ipw2200" b/g
> wireless
> chipset. Here is my "out of the box" fresh install
> experience:
> Download Colony 4 install iso image. Did md5sum
> check on it.
> Burned iso image to disk. Ran "md5sum -c" check on
> all files.
> Tried default boot. Got the usual, almost immediate,
> blank
> screen and no further disk activity, had to force
> power off.
> (Just thought I would try again, default has never
> worked on
> any other linux attempt on this machine).
> Tried "linux debian-installer/framebuffer=false"
> This worked, including configuring ie1 with the name
> and WEP
> key during installation. Installation completed
> successfully,
> there where no ipw2200 error messages in dmesg after
> logging
> in.
> Now the main problem: wifi does not work with
> firefox in any
> useful way.
> Here are the symptoms:
> This is a dual boot machine. Wifi works fine under
> windoze
> (sigh); signal strength is very high.
> Wifi also did not work correctly for me under ubuntu
> 5.04 or
> colony 3.
> Wifi actually works somewhat. For example, I can
> download
> updates via synaptic or the update manager (with
> occasional
> hiccups). But trying to use firefox, it is almost
> always
> impossible to get a web site to load, it usually
> hangs
> forever with "contacting google" (or any other site)
> in the
> firefox status line. Sometimes though, a page will
> load. With
> my limited knowledge, it acts like opening any new
> ip address
> is torture and likely to hang trying (after a long
> time,
> there is an error message that it can not contact
> the site).
> >From a bit of googling around, it appears that some
> folks are
> getting ipw2200 to work on their Dell 9300s -- by
> rebuilding
> the code pieces themselves. It seems though that the
> successful combinations of pieces for this machine
> configuration have not made it into ubuntu yet (or
> Fedora
> Core 4), probably because the developers do not have
> both the
> machine and wifi.
> Are there any simple things I can try?  Will adding
> "no_apic"
> to the boot line and re-installing help?  I am
> willing to
> wait until 5.10, though I wonder if the fix will be
> in that?
> (Lots of great stuff in ubuntu linux, if wifi was
> not my only
> connection at the moment I would have already
> switched!)
> Thanks.
> Click here to donate to the Hurricane Katrina relief
> effort.
> -- 
> ubuntu-users mailing list
> ubuntu-users at

Click here to donate to the Hurricane Katrina relief effort.

More information about the ubuntu-users mailing list