Setup pppoe on install/livecd

'Forum Post ulist at
Mon Oct 24 13:14:30 UTC 2005

(After something - suspected Hoary security update - rendered my PPPoE
connection broken after reboot...)

I finally gave up my blind troubleshooting attempts, disabled the
onboard Marvell Yukon on my ASUS board and installed a cheapo Realtek
(EP-320X-R) ethernet card. The MCNLive distro booted and ran pppoeconf
like a champ (as before). Next I tried booting Breezy Live and...
Voila! This time pppoeconf ran just fine, caught the "access
concentrators" from the server and I'm posting this from a Breezy
session. No editing of IPv6 or /etc/network/interfaces was needed.

Next I'll try if it works under my current Hoary HD install, but at
least I should be able to do a clean Breezy install and still get
network running if Hoary's networking is somehow terminally wounded.

This still poses the question why and how a long-working pppoe setup
was rendered broken. Which security update over the last few weeks
could've caused it? Did Hoary get updated (regressed) PPP recently?

Perhaps it has something to do with the ethernet card module, which was
"sk98lin" under the previous Marvell Yukon setup, and now "8139too" for
the Realtek card (lsmod shows that module "mii" is also linked to both
"8139too" and "8139cp").

I wonder if the Ubuntu developers should be alerted about a "potential
issue" with the Marvell Yukon before Canonical presses and ships off 10
million Breezy CDs? In any case, pppoe and the Yukon ethernet (sk98lin)
should be fixed to continue working since they already did under Hoary,
and they also work under under another distro (MCNLive).


More information about the ubuntu-users mailing list