Setup pppoe on install/livecd

'Forum Post ulist at
Sun Oct 23 22:32:52 UTC 2005

Jhair Tocancipa Triana Wrote: 


> I had similar problems with pppoe. I solved them running pppoeconf

> again. Under Breezy it adds the following lines to

> /etc/network/interfaces:


> <....>

> The ppp package went through massive changes in the Hoary->Breezy

> transition and, unfortunately, those changes are poorly documented

> (e.g. possible regressions, etc.).

Thanks for the reply, Jhair.

I had actually found that suggestion yesterday, and even tried putting
it to use, but I suspect I had already misconfigured something else and
therefore the fix (if it actually works on my setup) didn't kick in. I
think Hotplugging is flaky on my system, due to flaky BIOS/Via bugs/IRQ
issues, and for some reason Ubuntu is picky about the specific combo of
boot arguments (e.g. noapic, acpi=off, irqpoll) while the miniMandriva
Live just ran fine with its defaults. I tried booting Breezy Live using
different combination of those args after seeing the "hotplug" entry in
"/interfaces", but things just went downhill as I fiddled blindly. ;-)

Is the new IPv6 (as opposed to IPv4; I don't know when that changed...)
setup required under the new pppoe configuration?

Should the eth0 interface be specifically configured using the GNOME
"Networking" tool, or should that be avoided if there's no router to
connect to but just a dumb DSL "modem" using "access concentrators"?

If I do a clean Breezy install (to wipe out all network config changes
and misconfigurations I've made by now), what's involved in setting up
PPPoE the right way? Just running "pppoeconf" and making the above
correction to "/interfaces"?

If I try the RP-PPPoE package instead, is anything else involved except
installing and configuring pppoe through it? Like configuring or
bringing up eth0 or something manually?

Is there a way to reset the networking configuration to the original
setup (akin to reinstalling the whole OS) without reinstalling?

I hope in the future NetworkManager or any other user-friendly tool
gets this internet connectivity issue solved for the non-professional
users. Easy net access is now the major reason for using computers or
trying out Linux, and especially pppoe users don't have it too easy
right now. It is already hard enough trying to finding answers to some
configuration problems with working net access.

PS. I downloaded and tried setting up pppoe (without any tips or fixes)
under the latest Knoppix (4.02) as well, and it failed like Breezy Live
had. MCNLive (Jordaan) is saving my bacon here, but hopefully not for
too much longer. :^)


More information about the ubuntu-users mailing list