Audio playback problems

August Karlstrom fusionfive at
Sun Oct 16 13:21:06 UTC 2005

crimsun at wrote:
> On Sun, Oct 16, 2005 at 01:33:02AM +0200, August Karlstrom wrote:
>>When I run the sink test I hear a sound in the left channel only (as 
>>before). The source test (for OSS) produces no sound.
> You didn't happen to manually create an /etc/asound.conf or
> ~/.asoundrc, did you? 


    $ ls ~/.asoundrc
    ls: /home/august/.asoundrc: No such file or directory
    $ ls /etc/asound.conf
    ls: /etc/asound.conf: No such file or directory

>>With this setting I get an error when I run the test:
>>   Failed to construct test pipeline for 'Custom'
> Did you remember to uncheck System> Preferences> Sound> Enable sound
> server startup?

No I didn't (didn't know i should). When I did that and rebooted the
login time decreased dramatically and the standard GNOME applications is 
much more responsive. What a difference! System sounds should really 
have been disabled by default.

If I now choose OSS both as source and sink everything seems to work 
except the source test that fails with the same error message as before.

I'm glad that it now works, but I would really like to use the more 
modern ALSA driver.

>>Since everything works when I'm superuser the solution can't be that far 
>>away. It has to be some file permission issue.
> Sounds like a conffile issue.

Yes, but what configuration file?

By the way, my setup is (far from obscure)

Motherboard: Asus A7N8X-X
Processor: AMD XP 2500+
Memory: 512 MB
Sound Card: Audiophile 24/96
Graphics Card: ATI Radeon 9600 Pro

Thanks for your help,


More information about the ubuntu-users mailing list