MPlayer being Choppy

Wade Smart wade at
Mon Nov 14 18:25:39 UTC 2005

11142005 1210 GMT-5

1. What site to play?
2. What actual media page?
3. Connection Speed? 5000kbps down 1000kbps up
4. Wireless router? No
5. Processor? P4 630 3Ghz, 1GB ram
6. Video and sound card? On board for both - Intel
7. Streams download?  I do know how. I would like to not have to obviously.
8. Open url and download file? I havent tried this with xine.

I have not really understood opening a url with xine.

Results of xine-check:
wadesmart at wadesmart:~$ xine-check
Please be patient, this script may take a while to run...
[ good ] you're using Linux, doing specific tests
[ good ] looks like you have a /proc filesystem mounted.
[ good ] You seem to have a reasonable kernel version (2.6.12-9-386)
[ good ] intel compatible processor, checking MTRR support
[ good ] you have MTRR support and there are some ranges set.
[ good ] found the player at /usr/bin/xine
[ hint ] multiple xine executables found in your PATH
         I have found more than one occurance of 'xine' in your PATH:
         You have probably installed xine-ui more than once, or the 
         where you have installed xine occurs more than once in your PATH.
         Technically, this is not really a problem, but it's probably
         somewhat confusing, as it's not obvious, which xine you're using.
         You should probably uninstall the copies that you don't use...
         Further tests assume, you're using /usr/bin/X11/xine
         press <enter> to continue...

[OUCH!!] no xine-config on this machine.
         This means that xine-lib is either not installed
         or it is installed in a very unusual place.
         So you should probably install xine-lib before running 
         press <enter> to continue...

[ hint ] unable to determine plugin directory
         I could not determine your plugin directory. That would be much 
         if you had xine-config installed (see message above)...
         Note that I could not check your xine plugins.
         press <enter> to continue...

[ good ] /dev/cdrom points to /dev/hdc
[ good ] /dev/dvd points to /dev/hdc
[ hint ] DMA is disabled for your DVD interface.
         This will probably result in a serious performance hit when
         playing DVDs. You can issue the command
         hdparm -d1 /dev/hdc
         as root to enable DMA. It would be wise to add this command to
         some script that is executed executed at boot time.

         Note that you probably have to set the DMA mode for your drive 
as well.   
            Most DVD-ROMs work fine with multiword DMA mode 2. You can use
         hdparm -d1 -X34 /dev/hdc  (as root again) to set this mode. 
Maybe UDMA2 will give you even better        
         performance, but it only works well with some controllers. You'll
         probably need UDMA capable IDE cables for this mode. If you want
         to try: make backups of your important data and type (as root 
         hdparm -d1 -X66 /dev/hdc
         If your System still works fine after this, you probably want 
to keep
         these settings (add them to some boot script).
         If your system hangs or behaves very strangely after a few 
minutes, you        
        should reboot immediately and never use this setting again on this
         machine. Good luck ;-)
         press <enter> to continue...

[ good ] found xvinfo: X-Video Extension version 2.2
[ good ] your Xv extension supports YV12 overlays (improves MPEG 
[ good ] your Xv extension supports YUY2 overlays
[ good ] Xv ports:  YUY2 YV12 I420 UYVY

>Do you know how to download the stream to your machine?  If so, can you play 
>it back locally with more success?  If you do downloa dit, and play it from 
>terminal, does mplayer report any errors or warnings?
>Have you tried using xine to open the url or the downloaded file?  Can you run 
>xine-check for us, and see if it reports any problems?  (I think it always 
>reports missing plugins etc. on debian-based systems; just ignore that :)

More information about the ubuntu-users mailing list