system freeze installing libxine1

Todd Slater dontodd at
Sun Jun 26 15:57:05 UTC 2005

On Sun, Jun 26, 2005 at 01:02:54AM -0400, Todd Deshane wrote:
>    On 6/23/05, Todd Slater <[1]dontodd at> wrote:
>      I try to keep my system up to date, but I haven't been able to
>      install
>      recent updates because my system freezes when trying to install
>      libxine1.
>      When I run the update util (red icon notifying me updates are
>      available), it says some packages will be held back and that I need
>      to
>      run apt-get dist-upgrade or synaptic smart upgrade. Since I
>      couldn't
>      find anything like that in synaptic, I ran apt-get.
>      The smart upgrade option is in Settings->Preferences-> System
>    Upgrade:
>     but I don't think that is the problem that you are after.
>    try this
>     sudo apt-cache --installed rdepends libxine1
>    that should tell you which packages (filtering on the
>    installed ones) that depend on libxine1
>    for me it is only gxine.
>    then you can decide if you want to remove that package
>    and libxine1

sudo apt-cache --installed rdepends libxine1 reports that nothing depends on

So I tried removing it but got a message that the package was badly
broken and needed re-installed.

sudo apt-get install libxine1 dies on error:

Get:1 hoary-security/main libxine1
1.0-1ubuntu3.1 [3750kB]
Fetched 3750kB in 13s (281kB/s)

Preconfiguring packages ...
Selecting previously deselected package libxine1.
(Reading database ... 101668 files and directories currently installed.)
Preparing to replace libxine1 1.0-1ubuntu3 (using
.../libxine1_1.0-1ubuntu3.1_i386.deb) ...
Unpacking replacement libxine1 ...
dpkg: error processing
/var/cache/apt/archives/libxine1_1.0-1ubuntu3.1_i386.deb (--unpack):
 unable to install new version of `./usr/lib/xine/plugins/1.0.0/post':
Input/output error
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get remove libxine1 reports:

Removing libxine1 ...
dpkg: error processing libxine1 (--remove):
 cannot remove `/usr/lib/xine/plugins/1.0.0/':
Permission denied
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I seem to be running around in circles here; I can't remove it until I
fix it, but I can't fix it!

Thanks for your help,


More information about the ubuntu-users mailing list