/dev/dsp Permission Denied

Tom Betz ubuntu-users at tbetz.users.panix.com
Thu Jun 16 14:59:42 UTC 2005

Troy Davidson wrote:
> If I log in as my user, who setup KUbuntu on my box, I have sound and
> it works fine in all apps.
> But, I have users for my wife and son.  They log in and get a message
> saying something like "can't use audio.  /dev/dsp (Permission
> Denied)".  I look at /dev/dsp and it is RW for Root and Audio.

I ran into something similar last night (under KDE -- I have both KDE 
and Gnome installed), but logged in only as myself, a single user. 
Every audio app was locking up completely, except for 1by1 (which I run 
under wine) which told me that the WAV device was locked.  When I tried 
to log in to a Gnome session (as the same user), I was told that 
/dev/dsp was locked.  Even rebooting the system didn't fix it.

I ended up having to go into the Sound preferences settings and 
selecting the OSS input device, which then restarted the sound system 
and everything worked again.

Tom Betz, System Administrator
Greyston Foundation
Phone 914-376-3903 ext 230
Processing the finest bytes since 1982...

More information about the ubuntu-users mailing list